Opened 7 months ago

Closed 7 months ago

#1001 closed System Defect (fixed)

Unsupported DE & Production/Edge option is gone

Reported by: gour Owned by:
Priority: major Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

After yesterday's update, uname shows p4, although I'm not sure if it was displaying p5 earlier 'cause, iirc, Kris mentioned that there was no update for the kernel.

However, I'm experiencing another problem: clicking on several icons in Control Panel opens tabs in Firefox with *.desktop files and the following is reported in terminal:

gour  atmarama  ~  $ pc-controlpanel 
QMetaObject::connectSlotsByName: No matching signal for on_itemActivated(QListWidgetItem*)
Unsupported DE 

(process:36777): GLib-CRITICAL **: void g_slice_set_config(GSliceConfig, gint64): assertion 'sys_page_size == 0' failed

I'm worried about that ' Unsupported DE' (running i3) 'cause before the update everything was fine?

After running pc-sysmanager from the terminal, I see that the there is no longer option to select Production/Edge? for package set?

Change History (1)

comment:1 Changed 7 months ago by yurkis

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for report.
About patch number (-p5). freebsd-version command shows 10.0-RELEASE-p5, but uname is not fully correct.

Problem with .desktop files launch already fixed: https://github.com/pcbsd/pcbsd/commit/5e4607894dea8579b9b03d23efcbee901e2333ce It was not problem of 'unsupported' i3. Problem is in my head and hands. Sorry.

Package set selection was moved to the Package Manager. File->Configuration menu item. Looks like it is more suitable place for this setting.

Note: See TracTickets for help on using tickets.