Opened 5 months ago

Closed 5 months ago

#1025 closed Package Issue - EDGE (fixed)

Conflict detection is broken

Reported by: yurkis Owned by: kris
Priority: minor Milestone:
Component: Package Manager Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Looks like conflict detection is broken in pkg related UI tools at least in edge package set.

PS Please add Package Manager component for reporting in trac
PPS Please add ability to report which package set I'm using (maybe version 10-RELEASE / 10-RELEASE - edge)

Change History (3)

comment:1 Changed 5 months ago by kris

  • Component changed from System Tool to Package Manager
  • Owner set to kris
  • Type changed from System Defect to Package Issue - EDGE

I've added those new categories now. What kind of conflict was failing to get resolved?

comment:2 Changed 5 months ago by yurkis

That was reported by Joe Maloney here: http://lists.pcbsd.org/pipermail/testing/2014-February/009050.html
I can confirm. During update from the production to the Edge package set there was some gtk related packages conflict. But as I remember package UI dosnt ask to resolve them.

PS Thanks for the category creation

comment:3 Changed 5 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed now:

https://github.com/pcbsd/pcbsd/commit/953cbc3d9a40bc68cf4a54982d9b43c9b7f31222

If you still run into problems, re-open this ticket and attach the following output from these commands:

# pkg-static upgrade -FUy

# pc-updatemanager pkgupdate

Note: See TracTickets for help on using tickets.