#1031 closed System Defect (fixed)

warden- can not create linux jail

Reported by: yurkis Owned by:
Priority: major Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Reported here by Gour: http://lists.pcbsd.org/pipermail/testing/2014-February/009051.html

I can confirm not only debian jail but gentoo too.
Here is log from warden UI:

/usr/bin/uname
10.0-RELEASE-p4
DEF: 10.0-RELEASE-amd64
Setting up linux jail...
/usr/local/share/warden/scripts/backend/createjail.sh: cannot create /usr/jails/linjail/etc/master.passwd: Немає такого файлу або каталогу
mv: rename /usr/jails/linjail/tmp/master.passwd to /usr/jails/linjail/etc/: No such file or directory
mv: rename /usr/jails/linjail/tmp/pwd.db to /usr/jails/linjail/etc/: No such file or directory
mv: rename /usr/jails/linjail/tmp/spwd.db to /usr/jails/linjail/etc/: No such file or directory
rm: /usr/jails/linjail/tmp/passwd: No such file or directory
cp: /usr/jails/linjail/etc/resolv.conf: No such file or directory
chroot: /.fixSH: No such file or directory
Success! Linux jail created at /usr/jails/linjail
Changing root password on: chroot: /.chpass.sh: No such file or directory
FAILED!

Change History (1)

comment:1 Changed 11 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Fixed!

https://github.com/pcbsd/pcbsd/commit/5ae7c8ead4946f1ad0c6d8811304bef52536e9ee

Looks like it was a bad merge from some of the FreeNAS changes to warden.

Note: See TracTickets for help on using tickets.