Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#1034 closed PBI Packaging Bug (3rdpartybug)

Chromium 32.0.1700.107 Seg Fault

Reported by: na.weber Owned by:
Priority: minor Milestone:
Component: PBI System Version: 10.0-RELEASE
Keywords: chromium pbi Cc: trac-bugs@…

Description

Greetings,

The most recent Chromium PBI (v. 32.0.1700.107) is seg faulting on my 10.0-RELEASE system. Chromium appears to start, but will crash about 2 seconds after my home screen appears. Here is the output created during after Chromium attempts to start:

[user@system] ~% chrome
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
[57145:276849664:0214/215026:ERROR:profile_sync_service.cc(1200)] History Delete Directives datatype error was encountered: Delete directives not supported with encryption.
[57145:278001664:0214/215027:ERROR:download.cc(330)] PostClientToServerMessage?() failed during GetUpdates?
[57148:276852736:0214/215027:ERROR:ipc_channel_posix.cc(478)] pipe error on 3 Currently writing message of size: 28: Socket is not connected
Segmentation fault

It should be noted that the previous Chromium PBI (v.31 I believe) worked with no issues on the same 10.0-RELEASE system.

Thank you for the assistance, please let me know if any additional information is needed.

Nate

Change History (2)

comment:1 follow-up: Changed 5 months ago by kris

  • Resolution set to 3rdpartybug
  • Status changed from new to closed

I had the same thing happen here, and tracked it down to the "chromecast" extension causing a crash. Try running this:

% chrome --disable-extensions

If that works, then is indeed an extension that is bad..

I was able to use the instructions here to disable bad ones:

http://superuser.com/questions/254579/how-to-open-google-chrome-with-extensions-disabled-turned-off

Also, you can remove .config/chromium directory (which deletes all your local preferences) I then re-synced chrome from the cloud, and told it to ignore importing extensions.

comment:2 in reply to: ↑ 1 Changed 5 months ago by na.weber

Replying to kris:

I had the same thing happen here, and tracked it down to the "chromecast" extension causing a crash. Try running this:

% chrome --disable-extensions

If that works, then is indeed an extension that is bad..

I was able to use the instructions here to disable bad ones:

http://superuser.com/questions/254579/how-to-open-google-chrome-with-extensions-disabled-turned-off

Also, you can remove .config/chromium directory (which deletes all your local preferences) I then re-synced chrome from the cloud, and told it to ignore importing extensions.

Thanks Kris, the Chromecast extension was indeed the cause of the crashes I was experiencing. Chrome is now working following the steps you outlined below, thanks again for the assistance.

Note: See TracTickets for help on using tickets.