Opened 19 months ago

Closed 17 months ago

Last modified 15 months ago

#1041 closed PBI Packaging Bug (fixed)

Firefox Crashes KDE/Whole System

Reported by: matijadmin Owned by: kris
Priority: major Milestone:
Component: Misc Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…


Firefox on first lunch after installation from AppCafe? does not start and crashes KDE/whole system. System becomes unresponsive, I'm able to move mouse, change console and login as root but shell doesn't load properly and I can not reboot the systems softly (hard reset by pressing button is needed).

I can reapeat this bug by uninstalling and reinstalling Firefox.

I'm using up to date PC-BSD 10.0-RELEASE-p4. Bug was present in p3 already.

After creating jail with Warden, installing Firefox via packages inside and rebooting I can not run Firefox PBI installed from AppCafe? on my system anymore. I've uninstalled Firefox from packages and deleted jail. No luck. More details are here:

Attachments (7)

Xorg.0.log (13.3 KB) - added by matijadmin 19 months ago.
Xorg.0.log.old (13.7 KB) - added by matijadmin 19 months ago.
PCDM.log (925 bytes) - added by matijadmin 19 months ago.
PCDM.log.old (925 bytes) - added by matijadmin 19 months ago.
debug.log (12.2 KB) - added by matijadmin 19 months ago.
pbid.log (43 bytes) - added by matijadmin 19 months ago.
crashlog-530f4db8.txt (3.9 KB) - added by matijadmin 18 months ago.
Google Earth's crashlog-530f4db8.txt

Download all attachments as: .zip

Change History (21)

comment:1 Changed 19 months ago by joshms

  • Owner set to kris
  • Priority changed from critical to major

I get the same message about icons, but have so far been unable to duplicate any crashing. I'll keep trying. Let us know if you get any additional information from console related to the crash so we can troubleshoot this issue further.

comment:2 Changed 19 months ago by matijadmin

I replicated it today. KDE showed black skull as pointer. I was able to switch to console and see what is going on. Permissions problems. I was once again able to login as root but shell didnt load. I took pics with phone:
Errors in console
Shell not loaded

I can not determine what caused it; last update or ports jail created with Warden. I even installed Firefox and Crome with pkg inside jail when they coexisted on my system and were installed with AppCafe? from PBIs.

comment:3 Changed 19 months ago by matijadmin

And by the way I am not able to login to Gnome or Cinnamon anymore. Similar problems related to permissions are shown in console if not exactly same. I removed both from packages but login manager shows them both in dropdown menu. In case of unsuccessful login I am able to switch to console where shell after login loads properly. System does not crash completely.

comment:4 Changed 19 months ago by matijadmin

I'm using KDE where I used Warden when creating ports jail environment. KDE works fine.

Link to forum post:

Changed 19 months ago by matijadmin


Changed 19 months ago by matijadmin


Changed 19 months ago by matijadmin


Changed 19 months ago by matijadmin


Changed 19 months ago by matijadmin


Changed 19 months ago by matijadmin


comment:5 Changed 19 months ago by matijadmin

I updated Flash from ports and installed Firefox via pkg, result is here:

comment:6 Changed 19 months ago by matijadmin

I uninstalled Firefox pkg and installed it via AppCafe?. On first run I've experienced same nasty crash (I had to hard reset my PC). After that I wasn't able to run it due to inaccessible home dir but with su I it runs normally. I did not experience that crash with pkg installation (problems with inaccessible home dir were the same).

If you need any extra log, info, etc. I'll try to do my best.

comment:7 Changed 18 months ago by matijadmin

Since now I had problems with Chromium and Firefox PBIs crashing KDE/system on frist strat after installation.

Today I discovered that Google Earth PBI behaves the same, on first run after installation I had to push the reset buttn again.

Next time app didn't run and crashed but system remained stable. I get this in console:

Google Earth has caught signal 11.

We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:


Please include this file if you submit a bug report to Google.

Changed 18 months ago by matijadmin

Google Earth's crashlog-530f4db8.txt

comment:8 Changed 18 months ago by matijadmin

After updating Firefox from AppCafe? I've experienced system crash again on firs run.

Archivers (preinstalled from pgks by default on PC-BSD with KDE) have permissions related problem as well:

I suspect that all thoose problems KDE/system crash included are related to strange permissions behaviour. When I check owner of a dir/or file it looks OK but owner (who's running a specific app) in fact can't access it.

comment:9 Changed 18 months ago by helix

I can not confirm crashes on my system after first start of installed apps. But I did notice random crashes of plasma desktop on various occasions lately (for example when I delete file from my desktop). Yesterday I installed from latest iso to do some further testing (PCBSD10.0-RELEASE-p5-02-11-2014-x64-DVD-USB.iso) updated to p6 and recorded hickups during installation of Firefox (first part of movie, where you can see some "permission denied" flyby in AppCafe?). Second part is about how many times I had to click "Update" before LibreOffice? started to download. In video description you can find details about event time and my ip in case you can see in access logs what was happening.

Last edited 18 months ago by helix (previous) (diff)

comment:10 Changed 18 months ago by kenmoore

Are these crashes/hangs with the new pbifs container system (you re-built the pbi-manager from source recently)?
The new pbifs container has fixed a lot of these hangs/crashes that we have seen, so it might "just work" for you now once the package with the new format is pushed out (or you rebuild it from source).

comment:11 Changed 18 months ago by matijadmin

helix, I'm experiencing crashes only when starting particular apps installed from PBIs for first time after installation.

helix, you're right in sense that Plasma has some problems, may be with NVIDIA support/drivers.

I've noticed other problems related to PBI apps, those could be porting/packaging bugs.

I have some strange permission problems on my system (may be Warden is the case, I was playing with ports jail).

Gtk is another filed of problems, may be related to NVIDIA or permissions in my case.

I have troubles installing/updating from AppCafe? due to server/file unavailibility (I suppose it has nothing to do with described problems).

AppCafe? does not start by clicking desktop icon or even when calling it from console (or very rarely). I get Segmentation fault error. If I do left click on Update Manager it works every time. May be is this another independent problem from others described.

Version 0, edited 18 months ago by matijadmin (next)

comment:12 Changed 18 months ago by cabpa

On my system, i experienced applications not launching and returning Clutter errors like empathy, totem and cheese because I installed all metapackages including NVIDIA even if I do not have an nvidia card. Then I search in the internet and found solutions from forums to uninstall and reinstall nvidia, xorg and mesa driver. I uninstall nvidia from Package Manager Basic view but still the problem exist. I go to the Advanced view and tried to search with nvidia keyboard, i found that there are still nvidia packages in Advance View. So i uninstall all the remaining nvidia packages in Advance View. Then I restarted and tried launching empathy, totem and and suprisingly they launched successfully. Do the nvidia driver/packages creating a mess on the system in PC-BSD 10?

comment:13 Changed 17 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

This should (hopefully) be fixed with the updated PBI runtime.

Try that out and let me know how it works. If you still see failures, perhaps it is indeed a driver issue.

comment:14 Changed 15 months ago by matijadmin

Sure, it works.

Note: See TracTickets for help on using tickets.