Opened 2 months ago

Closed 5 weeks ago

#1051 closed PBI Packaging Bug (3rdpartybug)

gnumeric PBI can't save settings

Reported by: gour Owned by: ken
Priority: major Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Hello!

I've noticed that Gnumeric PBI does not save my settings to not use
compress for its files (which I keep uncompressed under Fossil DVCS) and
wondered what is the problem.

Running Gnumeric from console explains it:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings 
will not be saved or shared with other applications.

It does not happen neither with port version - all options OFF - nor
with pkg, so it seems it's due to PBI and isolated environment not
having access to 'global' dconf database?

In #gnumeric I'm told that dconf server is required, but I see that
dconf-service is running, but, probably, Gnumeric PBI can't access it?

One suggestion I got is to use:

--with-config-backend=keyfile

option for goffice build.

Any idea how to fix PBI to provide proper features?

Sincerely,
Gour

Change History (5)

comment:1 Changed 8 weeks ago by joshms

  • Owner set to ken

comment:2 Changed 6 weeks ago by kenmoore

  • Resolution set to fixed
  • Status changed from new to closed

I just rebuilt the math/gnumeric PBI locally with the devel/dconf package included and it appears to fix that warning about the "memory" settings backend.

I just committed the fix to the main build server as well, and will get an update PBI pushed out to the repo here soon.

Feel free to re-open the ticket if the new PBI still has the same issues.

https://github.com/pcbsd/pbi/commit/7de7aa29eec8a23172fdd21d452dc3e15edc5564

comment:3 Changed 5 weeks ago by gour

The new PBI solves the warning problem indeed, but the situation is now even worse - no warning, but Gnumeric still can't keep settings.

I notice it since I keep my *.gnumeric files under Git and therefore prefer uncompressed XML format:

Edit -> Preferences -> Files --> Default Comp. Level set to 0

but after restart it is again set to '9'.

So, according to the info which I got, the solution would be to build goffice with

--with-config-backend=keyfile

option, but the problem is that newer goffice-0.10 no longer has GCONF option which was present in goffice-0.8.

Any hint how to resolve it?

Sincerely,
Gour

comment:4 Changed 5 weeks ago by gour

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 5 weeks ago by kenmoore

  • Resolution set to 3rdpartybug
  • Status changed from reopened to closed

This sounds like the port needs to be updated to account for the different backends then.
I would send an email to the port maintainer[1] about this and include a link to this ticket as well.

[1] http://www.freshports.org/math/gnumeric

Note: See TracTickets for help on using tickets.