Opened 4 months ago

Closed 4 months ago

#1076 closed System Defect (deferred)

Swith User is not working in PC-BSD 10

Reported by: cabpa Owned by:
Priority: major Milestone: 9.2
Component: Misc Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

  1. Create a regular user in User Manager leaving the "Can administrate system" checkbox as unchecked.
  2. Logout and select Switch User

Observed behavior:
In Gnome, it returned a Dbus error. In LXDE, I cannot find the Switch User option during logout

Expected behavior:
Switch User should be available and working because I successfully created an additional regular user

My System is PC-BSD 10.0-Release-p4

Change History (1)

comment:1 Changed 4 months ago by kenmoore

  • Resolution set to deferred
  • Status changed from new to closed

Switching User requires a multi-session capable login manager, which PCDM is not (at the moment).
You will need to switch to using either GDM or KDM for your login manager instead to enable this feature.

To do this, modify /etc/rc.conf with the following changes and restart your system:

pcdm_enable="NO"
gdm_enable="YES" *or* kdm_enable="YES" (assuming you have GDM/KDM installed)

Note: See TracTickets for help on using tickets.