Opened 9 months ago

Closed 9 months ago

#1077 closed System Defect (duplicate)

Mount Tray requires root permissions on a regular user login

Reported by: cabpa Owned by:
Priority: major Milestone: 9.2
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Mount Tray requires root permissions to run on a regular user login. Below are the steps to reproduce:

  1. Create a regular user in User Manager leaving the "Can administrate system" checkbox as unchecked.
  2. Logout
  3. Login with the new user account and input its password

Observed behavior:
Notice that Mount Tray will not appear on the notification Area once you are logged in on the desktop environment. Try launching Mount Tray from the Control Panel but Mount Tray will not lauch.

Run pc-mounttray from a terminal and notice it will return a message saying that it requires root permissions.

Expected behavior:
Much better if Mount Tray does not require root permissions on regular users so that regular users can access their files on external usb drives

My System is PC-BSD 10.0-Release-p4

Change History (1)

comment:1 Changed 9 months ago by kenmoore

  • Resolution set to duplicate
  • Status changed from new to closed

This is a known limitation (not a bug) in the current mount tray implementation. Only "operators" can run root applications, hence the inability for "regular" users to use the mount tray.

See Ticket #934 for the root->user permissions feature request for the mount tray.

Note: See TracTickets for help on using tickets.