Opened 9 months ago

Closed 9 months ago

#1078 closed System Defect (fixed)

Sound Configuration does not launch from Control on a regular user login

Reported by: cabpa Owned by:
Priority: minor Milestone: 9.2
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Sound Configuration does not launch from Control on a regular user login. Below are the steps to reproduce

  1. Create a regular user in User Manager leaving the "Can administrate system" checkbox as unchecked.
  2. Logout and login with the new user account and input its password
  3. Launch Sound Configuration from Control Panel

Observe behavior:
Notice Sound Configuration does not launch

Try launching pc-soundconfig command from a terminal. Notice Sound Configuration GUI will launch

Expected behavior:
Sound Configuration should launch from Control Panel on a regular user login so that a regular user can test his Sound Configuration

My System is PC-BSD 10.0-Release-p4

Change History (1)

comment:1 Changed 9 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from new to closed

The sound configuration utility requires root permissions to run since it's sole purpose is to change the default sound device for the system. Once the system has been setup by an administrator, a "regular" user should have no need to access this utility. There is a new pc-mixer utility that is coming out soon for managing/controlling the user's sound settings. This utility should be used instead by a "regular" user.

I just put a check in place on the pc-soundconfig utility to make sure it does not startup if run with user permissions - making this distinction clearly visible when starting up the utility from the command line.

https://github.com/pcbsd/pcbsd/commit/9c8d91ac58c2b88eed5de12b4f94709591ff8fae

Note: See TracTickets for help on using tickets.