Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#1083 closed System Defect (fixed)

pc-mounttray closes up on its own

Reported by: gef_f Owned by:
Priority: major Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

The pc-mounttray program has started to close up on its own. Even if starting from the command line, it doesn't say why. Only thing I can think of that could be related to this is that I created zfs file system to an external USB disk, which I attached to the file system as usbtank. After removing it, the Life Preserver keeps telling it should be reattached on every reboot.

Fully updated PC-BSD 10.0.1.

Change History (4)

comment:1 Changed 12 months ago by gef_f

If I use zpool export/import to detach/attach the USB disk, there doesn't seem to be issues. So it looks like that the bug manifested when the zpool was in OFFLINE status.

comment:2 Changed 12 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from new to closed

This definitely sounded like something with your ZFS setup, since the mounttray does not have any support for mounting/unmounting ZFS volumes at the moment.

Glad you got it figured out!

comment:3 Changed 12 months ago by gef_f

What was the cause for the broken behavior?

comment:4 Changed 12 months ago by gef_f

Steps to reproduce the issue:
Create testpool out of any slice, in this case I'm using the third slice of an external USB drive:
# zpool create testpool da0s3

Yank the USB drive out. Resulting the following when looking with "zpool list"
testpool 216G 564K 216G 0% 1.00x UNAVAIL -

After a second or two, the pc-mounttray will terminate. And will continue do so every time it is launched again.

Clearing the zpool issue with:
# zpool clear testpool
# zpool destroy testpool
and the pc-mounttray will work correctly again.

Note: See TracTickets for help on using tickets.