Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#1125 closed System Defect (deferred)

App Cafe segfault on first launch

Reported by: bsddude Owned by: kenmoore
Priority: major Milestone:
Component: Software Manager Version: 10-STABLE
Keywords: App Cafe, Segfault Cc: trac-bugs@…

Description

App Cafe segfaults when launched for the first time after a fresh boot. Sometimes it would segfault several times before it would boot properly.

Attachments (1)

diagnostic-20140522.txt (25.7 KB) - added by bsddude 5 months ago.
Diagnostic sheet of the system

Download all attachments as: .zip

Change History (12)

Changed 5 months ago by bsddude

Diagnostic sheet of the system

comment:1 Changed 5 months ago by bsddude

I have commented the lines where the segfault occurs.

comment:2 Changed 5 months ago by kenmoore

  • Owner set to kenmoore
  • Status changed from new to assigned

Could you describe the conditions in which it seg-faults for you in a little better detail?
I noticed a number of other seg-faults in your diagnostic as well (pulse audio, kwin_opengl_test, pc-bluetoothtray) so there might be something else on your system that is mis-configured and is causing the issues.

Please report with:

1) PC-BSD Repo in use: (Production or Edge)
2) Is this a VM installation? (I see both virtualbox and vmware guest additions installed - so you might want to remove those if installed on real hardware)
3) Step-by-step procedure for me to try and reproduce the crash (since I cannot reproduce at the moment).

comment:3 Changed 5 months ago by bsddude

Hi Ken,

I've removed vmware and virtualbox. I also removed hplip and handheld metapackages to see if anything changed. Bellow is the updated diagnostic sheet.

PC-BSD 10.0-RELEASE-p11 Diagnostic Sheet
Generated: Tue May 27 11:53:10 PDT 2014

---------------PC-BSD Packages------------------------

pcbsd-base-1400071521
pcbsd-meta-development-1366133527
pcbsd-meta-development-qt-1389368442
pcbsd-meta-kde-1396637410
pcbsd-meta-kde-artwork-1366133527
pcbsd-meta-kde-graphics-1381943603
pcbsd-meta-kde-multimedia-1366133527
pcbsd-meta-kde-network-1366133527
pcbsd-meta-nvidia-1366133527
pcbsd-utils-1400867737
pcbsd-utils-qt4-1400868198

-----------------Dmesg Output-------------------------

Copyright (c) 1992-2014 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.0-RELEASE-p11 #0: Wed May 14 14:03:59 UTC 2014
    root@amd64-builder.pcbsd.org:/usr/obj/usr/src/sys/GENERIC amd64
FreeBSD clang version 3.3 (tags/RELEASE_33/final 183502) 20130610
CPU: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz (3399.08-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x306c3  Family = 0x6  Model = 0x3c  Stepping = 3
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x7fdafbbf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,<b11>,FMA,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x2c100800<SYSCALL,NX,Page1GB,RDTSCP,LM>
  AMD Features2=0x21<LAHF,ABM>
  Standard Extended Features=0x27ab<GSFSBASE,TSCADJ,BMI1,AVX2,SMEP,BMI2,ENHMOVSB,INVPCID>
  TSC: P-state invariant, performance statistics
real memory  = 9110028288 (8688 MB)
avail memory = 8188755968 (7809 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <ALASKA A M I>
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s)
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  2
 cpu2 (AP): APIC ID:  4
 cpu3 (AP): APIC ID:  6
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
random: <Software, Yarrow> initialized
cryptosoft0: <software crypto> on motherboard
aesni0: <AES-CBC,AES-XTS> on motherboard
acpi0: <ALASKA A M I> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 67, 1 (4) failed
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 550
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
Event timer "HPET3" frequency 14318180 Hz quality 440
Event timer "HPET4" frequency 14318180 Hz quality 440
atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
atrtc0: Warning: Couldn't map I/O.
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1808-0x180b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xe000-0xe07f mem 0xf4000000-0xf5ffffff,0xe8000000-0xefffffff,0xf0000000-0xf3ffffff irq 16 at device 0.0 on pci1
nvidia0: <GeForce GTX 560 Ti> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: Boot video device
hdac0: <NVIDIA GF110 HDA Controller> mem 0xf6080000-0xf6083fff irq 17 at device 0.1 on pci1
xhci0: <Intel Lynx Point USB 3.0 controller> mem 0xf6300000-0xf630ffff irq 16 at device 20.0 on pci0
xhci0: 32 byte context size.
xhci0: Port routing mask set to 0xffffffff
usbus0 on xhci0
pci0: <simple comms> at device 22.0 (no driver attached)
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xf6318000-0xf63183ff irq 16 at device 26.0 on pci0
usbus1: EHCI version 1.0
usbus1 on ehci0
hdac1: <Intel Lynx Point HDA Controller> mem 0xf6310000-0xf6313fff irq 22 at device 27.0 on pci0
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0
pci3: <ACPI PCI bus> on pcib3
pci3: <network, ethernet> at device 0.0 (no driver attached)
pcib4: <ACPI PCI-PCI bridge> irq 19 at device 28.7 on pci0
pci4: <ACPI PCI bus> on pcib4
re0: <RealTek 8168/8111 B/C/CP/D/DP/E/F/G PCIe Gigabit Ethernet> port 0xc000-0xc0ff mem 0xf6104000-0xf6104fff,0xf6100000-0xf6103fff irq 19 at device 0.0 on pci4
re0: Using 1 MSI-X message
re0: Chip rev. 0x2c000000
re0: MAC rev. 0x00200000
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211 1000BASE-T media interface> PHY 1 on miibus0
rgephy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
re0: Ethernet address: 10:fe:ed:08:24:52
ehci1: <EHCI (generic) USB 2.0 controller> mem 0xf6317000-0xf63173ff irq 23 at device 29.0 on pci0
usbus2: EHCI version 1.0
usbus2 on ehci1
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
ahci0: <Intel Lynx Point AHCI SATA controller> port 0xf070-0xf077,0xf060-0xf063,0xf050-0xf057,0xf040-0xf043,0xf020-0xf03f mem 0xf6316000-0xf63167ff irq 19 at device 31.2 on pci0
ahci0: AHCI v1.30 with 6 6Gbps ports, Port Multiplier not supported
ahcich0: <AHCI channel> at channel 0 on ahci0
ahcich1: <AHCI channel> at channel 1 on ahci0
ahcich2: <AHCI channel> at channel 2 on ahci0
ahcich3: <AHCI channel> at channel 3 on ahci0
ahciem0: <AHCI enclosure management bridge> on ahci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_button0: <Power Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
p4tcc1: <CPU Frequency Thermal Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
p4tcc2: <CPU Frequency Thermal Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3
p4tcc3: <CPU Frequency Thermal Control> on cpu3
ZFS filesystem version: 5
ZFS storage pool version: features support (5000)
Timecounters tick every 1.000 msec
hdacc0: <NVIDIA (0x0016) HDA CODEC> at cad 0 on hdac0
hdaa0: <NVIDIA (0x0016) Audio Function Group> at nid 1 on hdacc0
pcm0: <NVIDIA (0x0016) (HDMI/DP 8ch)> at nid 5 on hdaa0
hdacc1: <NVIDIA (0x0016) HDA CODEC> at cad 1 on hdac0
hdaa1: <NVIDIA (0x0016) Audio Function Group> at nid 1 on hdacc1
pcm1: <NVIDIA (0x0016) (HDMI/DP 8ch)> at nid 5 on hdaa1
hdacc2: <NVIDIA (0x0016) HDA CODEC> at cad 2 on hdac0
hdaa2: <NVIDIA (0x0016) Audio Function Group> at nid 1 on hdacc2
pcm2: <NVIDIA (0x0016) (HDMI/DP 8ch)> at nid 5 on hdaa2
hdacc3: <NVIDIA (0x0016) HDA CODEC> at cad 3 on hdac0
hdaa3: <NVIDIA (0x0016) Audio Function Group> at nid 1 on hdacc3
pcm3: <NVIDIA (0x0016) (HDMI/DP 8ch)> at nid 5 on hdaa3
hdacc4: <Realtek (0x0900) HDA CODEC> at cad 0 on hdac1
hdaa4: <Realtek (0x0900) Audio Function Group> at nid 1 on hdacc4
pcm4: <Realtek (0x0900) (Rear Analog 5.1/2.0)> at nid 20,22,21 and 24,26 on hdaa4
pcm5: <Realtek (0x0900) (Front Analog)> at nid 27 and 25 on hdaa4
pcm6: <Realtek (0x0900) (Rear Digital)> at nid 30 on hdaa4
random: unblocking device.
usbus0: 5.0Gbps Super Speed USB v3.0
usbus1: 480Mbps High Speed USB v2.0
usbus2: 480Mbps High Speed USB v2.0
ugen0.1: <0x8086> at usbus0
uhub0: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
ugen2.1: <Intel> at usbus2
uhub1: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
ugen1.1: <Intel> at usbus1
uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
ada0: <WDC WD10EZEX-00RKKA0 80.00A80> ATA-8 SATA 3.x device
ada0: Serial Number WD-WMC1S2622368
ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 953869MB (1953525168 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4
ada1 at ahcich1 bus 0 scbus1 target 0 lun 0
ada1: <ST31000528AS CC44> ATA-8 SATA 2.x device
ada1: Serial Number 6VPACXTS
ada1: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)
ada1: Command Queueing enabled
ada1: 953869MB (1953525168 512 byte sectors: 16H 63S/T 16383C)
ada1: Previously was known as ad6
ada2 at ahcich2 bus 0 scbus2 target 0 lun 0
ada2: <WDC WD800JD-75MSA3 10.01E04> ATA-7 SATA 2.x device
ada2: Serial Number WD-WMAM9FL61768
ada2: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)
ada2: Command Queueing enabled
ada2: 76293MB (156250000 512 byte sectors: 16H 63S/T 16383C)
ada2: Previously was known as ad8
ses0 at ahciem0 bus 0 scbus4 target 0 lun 0
ses0: <AHCI SGPIO Enclosure 1.00 0001> SEMB S-E-S 2.00 device
cd0 at ahcich3 bus 0 scbus3 target 0 lun 0
cd0: <TSSTcorp CDDVDW SH-222AB SB00> Removable CD-ROM SCSI-0 device 
cd0: Serial Number R8BZ6GHB347046
cd0: 150.000MB/s transfers (SATA 1.x, UDMA5, ATAPI 12bytes, PIO 8192bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
ses0: SEMB SES Device
Netvsc initializing... SMP: AP CPU #3 Launched!
SMP: AP CPU #2 Launched!
SMP: AP CPU #1 Launched!
Timecounter "TSC-low" frequency 1699541512 Hz quality 1000
Root mount waiting for: usbus2 usbus1 usbus0
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub0: 21 ports with 21 removable, self powered
Root mount waiting for: usbus2 usbus1 usbus0
xhci0: Port routing mask set to 0x00000000
usb_alloc_device: device init 2 failed (USB_ERR_IOERROR, ignored)
ugen0.2: <Unknown> at usbus0 (disconnected)
uhub_reattach_port: could not allocate new device
ugen1.2: <vendor 0x8087> at usbus1
uhub3: <vendor 0x8087 product 0x8008, class 9/0, rev 2.00/0.05, addr 2> on usbus1
ugen2.2: <vendor 0x8087> at usbus2
uhub4: <vendor 0x8087 product 0x8000, class 9/0, rev 2.00/0.05, addr 2> on usbus2
uhub3: 6 ports with 6 removable, self powered
uhub4: 8 ports with 8 removable, self powered
Root mount waiting for: usbus2 usbus1
ugen1.3: <Sony Computer Entertainment> at usbus1
Root mount waiting for: usbus2 usbus1
ugen1.4: <Broadcom Corp> at usbus1
Root mount waiting for: usbus2
ugen2.3: <JMicron> at usbus2
umass0: <MSC Bulk-Only Transport> on usbus2
umass0:  SCSI over Bulk-Only; quirks = 0x4100
umass0:5:0:-1: Attached to scbus5
(probe0:umass-sim0:0:0:0): REPORT LUNS. CDB: a0 00 00 00 00 00 00 00 00 10 00 00 
(probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(probe0:umass-sim0:0:0:0): SCSI status: Check Condition
(probe0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:20,0 (Invalid command operation code)
(probe0:umass-sim0:0:0:0): Error 22, Unretryable error
da0 at umass-sim0 bus 0 scbus5 target 0 lun 0
da0: <Jmicron generic 2009> Fixed Direct Access SCSI-6 device 
da0: Serial Number 2011010703041333
da0: 40.000MB/s transfers
da0: 1907728MB (3907028988 512 byte sectors: 255H 63S/T 243201C)
da0: quirks=0x2<NO_6_BYTE>
ugen2.4: <Logitech> at usbus2
ums0: <Logitech USB Gaming Mouse, class 0/0, rev 2.00/52.00, addr 4> on usbus2
ums0: 16 buttons and [XYZT] coordinates ID=0
Trying to mount root from zfs:BSDunix/ROOT/beforeUpdate-2014-05-13_23-56-43 []...
Cuse4BSD v0.1.33 @ /dev/cuse
ubt0: <Broadcom Corp BCM920702 Bluetooth 4.0, rev 2.00/1.12, addr 4> on usbus1
pefs: AESNI hardware acceleration enabled
fuse-freebsd: version 0.4.4, FUSE ABI 7.8
uaudio0: <Wireless Stereo Headset> on usbus1
uaudio0: Play: 48000 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 44100 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 32000 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 24000 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 22050 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 16000 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 11025 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Play: 8000 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 16000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: No MIDI sequencer.
pcm7: <USB audio> on uaudio0
uaudio0: No HID volume keys found.
uhid0: <Logitech USB Gaming Mouse, class 0/0, rev 2.00/52.00, addr 4> on usbus2
WARNING: attempt to domain_add(bluetooth) after domainfinalize()
WARNING: attempt to domain_add(netgraph) after domainfinalize()
uhid1: <Wireless Stereo Headset> on usbus1
ipfw2 (+ipv6) initialized, divert loadable, nat loadable, default to deny, logging disabled
pid 1994 (pulseaudio), uid 1001: exited on signal 6
pid 2176 (kwin_opengl_test), uid 1001: exited on signal 11
pid 3460 (kwin_opengl_test), uid 1001: exited on signal 11

-----------------Messages Output----------------------

May 27 11:49:42 pcbsd-4507 hp-upgrade: hp-upgrade[2714]: warning:  distro is not found in AUTH_TYPES
May 27 11:50:36 pcbsd-4507 console-kit-daemon[1479]: WARNING: Error waiting for native console 1 activation: Device not configured
May 27 11:50:36 pcbsd-4507 console-kit-daemon[1479]: WARNING: Error waiting for native console 9 activation: Device not configured
May 27 11:50:44 pcbsd-4507 devd: check_clients:  dropping disconnected client
May 27 11:51:07 pcbsd-4507 devd: notify_clients: write() failed; dropping unresponsive client
May 27 11:51:29 pcbsd-4507 pulseaudio[3359]: [(null)] pid.c: Stale PID file, overwriting.
May 27 11:51:29 pcbsd-4507 pulseaudio[3359]: [(null)] oss-util.c: '/dev/dsp0' doesn't support full duplex
May 27 11:51:29 pcbsd-4507 pulseaudio[3359]: [(null)] oss-util.c: '/dev/dsp1' doesn't support full duplex
May 27 11:51:29 pcbsd-4507 pulseaudio[3359]: [(null)] oss-util.c: '/dev/dsp2' doesn't support full duplex
May 27 11:51:29 pcbsd-4507 pulseaudio[3359]: [(null)] oss-util.c: '/dev/dsp3' doesn't support full duplex
May 27 11:51:30 pcbsd-4507 pulseaudio[3359]: [(null)] oss-util.c: '/dev/dsp6' doesn't support full duplex
May 27 11:51:32 pcbsd-4507 kernel: pid 3460 (kwin_opengl_test), uid 1001: exited on signal 11
May 27 11:51:35 pcbsd-4507 vmusr[3480]: [ warning] [GLib-GObject] Attempt to add property ToolsCoreService::tcs-app-ctx after class was initialised
May 27 11:51:35 pcbsd-4507 vmusr[3480]: [ warning] [GLib-GObject] Attempt to add property ToolsCoreService::tcs-prop-thread-pool after class was initialised
May 27 11:51:35 pcbsd-4507 vmusr[3480]: [ warning] [vmtoolsd] The vmusr service needs to run inside a virtual machine.
May 27 11:51:35 pcbsd-4507 hp-systray: hp-systray[3494]: error: option -s not recognized
May 27 11:51:37 pcbsd-4507 pulseaudio[3558]: [(null)] pid.c: Daemon already running.
May 27 11:51:37 pcbsd-4507 pulseaudio[3573]: [(null)] pid.c: Daemon already running.
May 27 11:52:03 pcbsd-4507 hp-upgrade: hp-upgrade[3936]: warning:  distro is not found in AUTH_TYPES
May 27 11:52:29 pcbsd-4507 hp-toolbox: hp-toolbox(UI)[10089]: warning:  distro is not found in AUTH_TYPES

------------------pciconf-----------------------------

hostb0@pci0:0:0:0:	class=0x060000 card=0x0c001849 chip=0x0c008086 rev=0x06 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Haswell DRAM Controller'
    class      = bridge
    subclass   = HOST-PCI
pcib1@pci0:0:1:0:	class=0x060400 card=0x0c011849 chip=0x0c018086 rev=0x06 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Haswell PCI Express x16 Controller'
    class      = bridge
    subclass   = PCI-PCI
xhci0@pci0:0:20:0:	class=0x0c0330 card=0x8c311849 chip=0x8c318086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point USB xHCI Host Controller'
    class      = serial bus
    subclass   = USB
none0@pci0:0:22:0:	class=0x078000 card=0x8c3a1849 chip=0x8c3a8086 rev=0x04 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point MEI Controller'
    class      = simple comms
ehci0@pci0:0:26:0:	class=0x0c0320 card=0x8c2d1849 chip=0x8c2d8086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point USB Enhanced Host Controller'
    class      = serial bus
    subclass   = USB
hdac1@pci0:0:27:0:	class=0x040300 card=0x11511849 chip=0x8c208086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point High Definition Audio Controller'
    class      = multimedia
    subclass   = HDA
pcib2@pci0:0:28:0:	class=0x060400 card=0x8c101849 chip=0x8c108086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:28:3:	class=0x060400 card=0x8c161849 chip=0x8c168086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib4@pci0:0:28:7:	class=0x060400 card=0x8c1e1849 chip=0x8c1e8086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
ehci1@pci0:0:29:0:	class=0x0c0320 card=0x8c261849 chip=0x8c268086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point USB Enhanced Host Controller'
    class      = serial bus
    subclass   = USB
isab0@pci0:0:31:0:	class=0x060100 card=0x8c441849 chip=0x8c448086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point LPC Controller'
    class      = bridge
    subclass   = PCI-ISA
ahci0@pci0:0:31:2:	class=0x010601 card=0x8c021849 chip=0x8c028086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point 6-port SATA Controller 1 [AHCI mode]'
    class      = mass storage
    subclass   = SATA
none1@pci0:0:31:3:	class=0x0c0500 card=0x8c221849 chip=0x8c228086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point SMBus Controller'
    class      = serial bus
    subclass   = SMBus
vgapci0@pci0:1:0:0:	class=0x030000 card=0x23821462 chip=0x120010de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GF114 [GeForce GTX 560 Ti]'
    class      = display
    subclass   = VGA
hdac0@pci0:1:0:1:	class=0x040300 card=0x23821462 chip=0x0e0c10de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GF114 HDMI Audio Controller'
    class      = multimedia
    subclass   = HDA
none2@pci0:3:0:0:	class=0x020000 card=0xe0911849 chip=0xe0911969 rev=0x10 hdr=0x00
    vendor     = 'Atheros Communications Inc.'
    class      = network
    subclass   = ethernet
re0@pci0:4:0:0:	class=0x020000 card=0x34687470 chip=0x816810ec rev=0x06 hdr=0x00
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    device     = 'RTL8111/8168B PCI Express Gigabit Ethernet controller'
    class      = network
    subclass   = ethernet

------------------xorg.conf---------------------------

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 310.14  (root@pcbsd-100-RELEASE-pcbsdports-job-04)  Wed Jan 15 23:30:26 UTC 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/local/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"
    FontPath        "/usr/local/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

------------------RC File-----------------------------

# Auto-Enabled NICs from pc-sysinstall

wlans_run0="wlan0"

ifconfig_wlan0="WPA SYNCDHCP"

# Auto-Enabled NICs from pc-sysinstall

hostname="pcbsd-4507"

zfs_enable="YES"

ifconfig_re0_ipv6="inet6 accept_rtadv"

ifconfig_re0="DHCP"

plexmediaserver_enable="YES"

pf_rules="/etc/pf.conf"
vboxnet_enable="YES"

------------------Loader File-------------------------

# * IMPORTANT NOTICE *
# Run 'grub-mkconfig -o /boot/grub/grub.cfg' after making changes to this file
###############################################################################
vboxdrv_load="YES"
nvidia_load="YES"
drm_load="YES"
vboxguest_load="YES"
vboxvideo_load="YES"
vfs.root.mountfrom="zfs:BSDunix/ROOT/beforeUpdate-2014-05-13_23-56-43"
zfs_load="YES"

------------------Free Space--------------------------

Filesystem                                            1M-blocks  Used  Avail Capacity  Mounted on
BSDunix/ROOT/beforeUpdate-2014-05-13_23-56-43            859935 15387 844548     2%    /
devfs                                                         0     0      0   100%    /dev
procfs                                                        0     0      0   100%    /proc
linprocfs                                                     0     0      0   100%    /compat/linux/proc
BSDunix/tmp                                              844548     0 844548     0%    /tmp
BSDunix/usr/home                                         867618 23070 844548     3%    /usr/home
BSDunix/usr/home/bsddude                                 874521 29973 844548     3%    /usr/home/bsddude
BSDunix/usr/jails                                        844548     0 844548     0%    /usr/jails
BSDunix/usr/jails/.warden-template-10.0-RELEASE-amd64    844763   214 844548     0%    /usr/jails/.warden-template-10.0-RELEASE-amd64
BSDunix/usr/jails/plexserver                             845409   861 844548     0%    /usr/jails/plexserver
BSDunix/usr/obj                                          844548     0 844548     0%    /usr/obj
BSDunix/usr/pbi                                          844667   119 844548     0%    /usr/pbi
BSDunix/usr/ports                                        844548     0 844548     0%    /usr/ports
BSDunix/usr/ports/distfiles                              844599    51 844548     0%    /usr/ports/distfiles
BSDunix/usr/src                                          844548     0 844548     0%    /usr/src
BSDunix/var/audit                                        844548     0 844548     0%    /var/audit
BSDunix/var/log                                          844549     0 844548     0%    /var/log
BSDunix/var/tmp                                          844649   101 844548     0%    /var/tmp

------------------System Processes--------------------

last pid: 10174;  load averages:  0.33,  0.49,  0.29  up 0+00:06:24    11:53:10
108 processes: 1 running, 107 sleeping

Mem: 621M Active, 341M Inact, 1175M Wired, 2864K Cache, 5720M Free
ARC: 838M Total, 296M MFU, 513M MRU, 788K Anon, 5753K Header, 23M Other
Swap: 4096M Total, 4096M Free


  PID USERNAME    THR PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
 3216 root          1  22   -1  3364M   163M select  2   0:05   5.27% Xorg
 3462 bsddude       4  52    0   951M   200M select  0   0:03   3.86% kdeinit4
 3459 bsddude       4  52    0   678M   118M kqread  0   0:01   0.98% kwin
10081 bsddude       2  20    0   325M 53692K select  2   0:00   0.20% pc-bugreport
 1335 root          1  20    0 14572K  1924K select  3   0:01   0.10% powerd
 3584 bsddude       8  23    0   132M 19360K uwait   2   0:00   0.10% tracker-store
 3359 bsddude       9  20    0   245M 10560K select  1   0:11   0.00% pulseaudio
 1487 plex         14  35   15   217M 63272K select  2   0:03   0.00% python
 3539 bsddude       4  39   19 79992K 46852K uwait   2   0:02   0.00% virtuoso-t
 1409 messagebus    1  20    0 17212K  3840K select  1   0:02   0.00% dbus-daemon
 1679 haldaemon     2  25    0 60824K  8852K select  1   0:01   0.00% hald
 3482 bsddude       3  20    0   790M   136M select  0   0:01   0.00% kdeinit4
 3438 bsddude       5  20    0   687M   112M select  1   0:01   0.00% kdeinit4
 4028 bsddude       1  20    0   329M 55980K select  0   0:01   0.00% pc-controlpanel
 3454 bsddude       7  26    0   371M 58316K kqread  0   0:01   0.00% kactivitymanagerd
 3486 bsddude       3  39   19   342M 59952K kqread  0   0:00   0.00% nepomukstorage
 3602 bsddude       4  44   19   346M 57044K select  3   0:00   0.00% nepomukfilewatch
 3603 bsddude       2  42   19   321M 52524K kqread  1   0:00   0.00% nepomukfileindexer

I use the edge package set. The installation is bare metal. I noticed that the crash for App Cafe happens when I first boot the computer. My Default DE is KDE. When I launch App Cafe from the desktop shortcut that's when I get the crashes. I tried launching it from the control panel and from the application launcher and it seems crash free. Once I get to successfully launch App Cafe the next time I launch it from the desktop it doesn't crash.

The pc-bluetoothtray crashes when I click it in the system tray. It's reproducible by entering the bluetooth manager app in the PCBSD Control Panel and clicking the start tray application. Once the bluetooth icon appears, left or right clicking it segfaults the program.

The Kwin OpenGL test fail happens from time to time when booting into KDE from a cold system boot. The KDE loading screen would freeze once the screwdriver/wrench iconset would blur in. I'm not successful in reproducing this error.

comment:4 Changed 5 months ago by kenmoore

Could you try launching the AppCafe? from a desktop environment other than KDE to see if that helps narrow down the problem? I have seen a few other bugs with launching applications recently that were all caused by various KDE subsystems.

comment:5 Changed 5 months ago by bsddude

Tried with Lumina. 2 out of 5 times it crashed. Here's the relevant dmesg output:

pid 1422 (Plex Media Server), uid 972: exited on signal 11
pid 2051 (pulseaudio), uid 1001: exited on signal 11
pid 3010 (pc-softwaremanager), uid 0: exited on signal 11
pid 3252 (pc-softwaremanager), uid 0: exited on signal 11

I just logged into Lumina and launched App Cafe by using the 'star' button on the top panel, beside the 'username button.'

comment:6 Changed 5 months ago by bsddude

This is the output in LXDE. I launched it the same way as in KDE, from the shortcut on the desktop. Got one successful launch out of 6 tries.

pid 1415 (Plex Media Server), uid 972: exited on signal 11
pid 1840 (PCDM-session), uid 0: exited on signal 11
pid 2174 (PCDM-session), uid 0: exited on signal 11
pid 3059 (pc-softwaremanager), uid 0: exited on signal 11
pid 3099 (pc-softwaremanager), uid 0: exited on signal 11
pid 4580 (pc-softwaremanager), uid 0: exited on signal 11
pid 4604 (pc-softwaremanager), uid 0: exited on signal 11
pid 4634 (pc-softwaremanager), uid 0: exited on signal 11
pid 2830 (pc-bluetoothtray), uid 0: exited on signal 11

comment:7 Changed 5 months ago by bsddude

In Mate the entire desktop seemed unstable but I guess it's an unsupported DE so it should be expected. I was able to launch App Cafe only once in 5 tries. Furthermore, the Control Panel segfaulted three times.

pid 2335 (PCDM-session), uid 0: exited on signal 11
pid 5428 (pulseaudio), uid 1001: exited on signal 11
pid 5539 (mate-power-manager), uid 1001: exited on signal 11
pid 5756 (pc-bluetoothtray), uid 0: exited on signal 11
pid 6189 (pc-softwaremanager), uid 0: exited on signal 11
pid 6250 (pc-softwaremanager), uid 0: exited on signal 11
pid 6309 (pc-softwaremanager), uid 0: exited on signal 11
pid 6712 (pc-controlpanel), uid 1001: exited on signal 11

comment:8 Changed 5 months ago by kenmoore

Stay tuned, we have finally been able to reproduce this on one of the computers of a PC-BSD developer.
It appears to be an issue with the Qt single instance framework at the moment (or some Qt bit(s) missing in the default install), but we are still looking to it.

Could you paste the output of "pkg query -a %o-%v | grep qt"?

comment:9 Changed 5 months ago by bsddude

pkg query -a %o-%v | grep qt
multimedia/gstreamer-qt4-0.10.3_2
x11-themes/gtk-qt4-engine-1.1_10
x11-themes/qtcurve-gtk2-1.8.16
x11-themes/qtcurve-kde4-1.8.14_2
devel/libdbusmenu-qt-0.9.2_2
devel/p5-perlqt-4.12.5
misc/pcbsd-meta-development-qt-1389368442
sysutils/pcbsd-utils-qt4-1401308853
sysutils/polkit-qt-0.103.0_1
graphics/poppler-qt4-0.24.5_1
devel/py-qt4-4.10.3_1
devel/py-qt4-assistant-4.10.3,1
devel/py-qt4-core-4.10.3,1
devel/py-qt4-dbus-4.10.3,1
devel/py-qt4-dbussupport-4.10.3
devel/py-qt4-declarative-4.10.3
misc/py-qt4-demo-4.10.3,1
devel/py-qt4-designer-4.10.3,1
devel/py-qt4-designerplugin-4.10.3_1,1
misc/py-qt4-doc-4.10.3,1
x11-toolkits/py-qt4-gui-4.10.3,1
devel/py-qt4-help-4.10.3
multimedia/py-qt4-multimedia-4.10.3
net/py-qt4-network-4.10.3,1
x11/py-qt4-opengl-4.10.3,1
multimedia/py-qt4-phonon-4.10.3_1
devel/py-qt4-qscintilla2-2.7.2,1
devel/py-qt4-script-4.10.3,1
devel/py-qt4-scripttools-4.10.3,1
databases/py-qt4-sql-4.10.3,1
graphics/py-qt4-svg-4.10.3,1
devel/py-qt4-test-4.10.3,1
www/py-qt4-webkit-4.10.3
textproc/py-qt4-xml-4.10.3,1
textproc/py-qt4-xmlpatterns-4.10.3
devel/qt4-assistant-4.8.6
devel/qt4-assistant-adp-4.6.3_1
textproc/clucene-qt4-4.8.6
devel/qt4-corelib-4.8.6
devel/dbus-qt4-4.8.6                                                                                      
x11-toolkits/qt4-declarative-4.8.6                                                                        
devel/qt4-designer-4.8.6                                                                                  
misc/qt4-doc-4.8.6
x11-toolkits/qt4-gui-4.8.6
devel/qt4-help-4.8.6
devel/qt4-help-tools-4.8.6
graphics/qt4-iconengines-4.8.6
graphics/qt4-imageformats-4.8.6
x11/qt4-inputmethods-4.8.6
devel/qt4-libqtassistantclient-4.6.3_1
devel/qt4-linguist-4.8.6
devel/qt4-moc-4.8.6
multimedia/qt4-multimedia-4.8.6
databases/qt4-mysql-plugin-4.8.6
net/qt4-network-4.8.6
graphics/qt4-opengl-4.8.6
graphics/qt4-pixeltool-4.8.6
devel/qt4-porting-4.8.6
devel/qt4-qdbusviewer-4.8.6
devel/qt4-qt3support-4.8.6
devel/qt4-qtsolutions-singleapplication-20110722_1
devel/qt4-qvfb-4.8.6
devel/qt4-rcc-4.8.6
devel/qt4-script-4.8.6
devel/qt4-scripttools-4.8.6
databases/qt4-sql-4.8.6
databases/qt4-sqlite3-plugin-4.8.6
x11-themes/qtcurve-qt4-1.8.14
graphics/qt4-svg-4.8.6
devel/qt4-testlib-4.8.6
devel/qt4-uic-4.8.6
www/webkit-qt4-4.8.6
textproc/qt4-xml-4.8.6
textproc/qt4-xmlpatterns-4.8.6
textproc/qt4-xmlpatterns-tool-4.8.6
devel/qtcreator-2.8.0_3
devel/qtscriptgenerator-0.2.0_2
devel/ruby-qtruby-4.12.5
devel/smokeqt-4.12.5

comment:10 Changed 5 months ago by kenmoore

  • Resolution set to deferred
  • Status changed from assigned to closed

I think I fixed this in source now.
Looks like a library was staying in memory if you compile it on your system manually, but if installed through pkg it was not reliably linking to that lib.

Please retest after the next package update, and reopen the ticket if necessary.

comment:11 Changed 5 months ago by bsddude

Thank you for your help, it is very much appreciated.

Note: See TracTickets for help on using tickets.