Opened 5 months ago

Closed 2 months ago

#1171 closed System Defect (deferred)

AppCafe "loading" screen disappears when clicked

Reported by: joshms Owned by: ken
Priority: minor Milestone:
Component: Software Manager Version: 10.3
Keywords: Cc: trac-bugs@…

Description

When starting AppCafe? the loading screen will appear after entering a password. If you click on the loading mug icon it will immediately disappear. Expected behavior: loading screen stays static if clicked and does not disappear.

Change History (4)

comment:1 Changed 5 months ago by kenmoore

  • Resolution set to wontfix
  • Status changed from new to closed

This is by design for splash screens in general.
Since a splash screen always shows *above* any other windows, the user needs to have a way to hide it and continue using their system while the application is starting.

comment:2 Changed 4 months ago by joshms

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version changed from 10.0.2-RC1 to 10.3

re-opened for 10.3. Kris thinks we can write our own class to help add this functionality since there is no easy way to implement it in qsplashscreen.

comment:3 Changed 4 months ago by kris

Yea, lets target a fix for 10.0.3. Ken, perhaps add a new QSplashScreen class to libpcbsd.

comment:4 Changed 2 months ago by joshms

  • Resolution set to deferred
  • Status changed from reopened to closed

Ticket migrated. Closing.

Note: See TracTickets for help on using tickets.