#1183 closed System Defect (fixed)

Warden incorrectly reports jails as Running

Reported by: rpoyner@… Owned by:
Priority: minor Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: warden jails Cc: trac-bugs@…

Description

Warden reports jails as running even when jls does not show them.

This seems to be an issue warden/scripts/backend/checkstatus.sh

This script returns 0 aka "Running" on either of 2 conditions.

  1. The jail shows up as running in jls
  1. mount | grep -e ${JAILDIR}/ is true.

The problem is that if there are additional zfs datasets under ${JAILDIR} then the second condition is always true.

I don't understand the warden code well enough at this point to know the reason for the second check, but it seems like the mount check should be separated from checkstatus.sh. That would make checkstatus a clean running/not running check. The status of the mounts could be tested separately as needed.

Russ Poyner

Change History (1)

comment:1 Changed 15 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Fixed!

https://github.com/pcbsd/pcbsd/commit/6d06bd191fe140361b5d4e3c396d1da5f4c4f3bf

It was some left-over from how we used to check if it was safe to remove a jail using "rm -rf". I've fixed it now so that it only does that second check before trying to remove a jail from the box.

Note: See TracTickets for help on using tickets.