Opened 7 years ago

Closed 6 years ago

#119 closed System Defect (invalid)

X corrupted? after version 1.5 update or fresh install

Reported by: digital_smith Owned by:
Priority: major Milestone:
Component: System Configuration Version: 1.5
Keywords: Cc:

Description

I've been using PC-BSD as one of three Operating Systems on my eMachines M5312 laptop the last few years. Its worked great and has been less trouble for me than WinXP or Suse.

I recently had to replace the harddrive and did a fresh install of everything including PC-BSD and this time installed 1.5 fresh (Previous install was 1.3, I'm bad about updating). Installation went well, and I was able to boot it up, but when I should have been presented with a GUI asking for my desktop settings, I instead got a garbled desktop image (see attached pic). The cursor was rendered correctly and moved around, but I couldn't proceed any further. Interestingly, the installation GUI for 1.5 appeared to correctly detect that I had a 16:10 ratio display, whereas previous versions simply rendered a 4:3 image (images stretched out). Just in case I had messed something up, I reinstalled over it with the same result. I then did a fresh install over the same partition with version 1.4.1 and no problem, I got the desktop settings GUI (providing 1280x800,24bit,ati-3d-enable) and everything displayed and worked perfectly. I then booted from the 1.5 CD and chose the update option, and the condition recurred upon reboot. The last thing I could read was "Starting X".

FYI, there doesn't appear to be a 1.5 version choice in the ticket menu.

Specs of my laptop include ATI radeon mobility 320M, 1GB RAM (128MB shared to video), 15.4" WXGA LCD display. When configuring 1.4.1, it wasn't necessary to configure custom refresh rates, the defaults work.

I will say that of the three OSes, PC-BSD was the simplest and quickest installation.

Thanks for a great Desktop OS,

Dave

Attachments (1)

IMAGE_00024.jpg (54.6 KB) - added by digital_smith 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by digital_smith

comment:1 Changed 7 years ago by Hopkins

Here's a cross reference to my similar ticket:

http://trac.pcbsd.org/ticket/122

comment:2 Changed 7 years ago by nomedias

  • Version changed from 1.4.1 to 1.5

comment:3 Changed 6 years ago by kris

  • Resolution set to invalid
  • Status changed from new to closed

Please re-open if this bug still occurs on 7.x. We've moved from Xorg 7.2 to 7.4, and with it a bunch of new drivers which fixed a lot of these issues.

Note: See TracTickets for help on using tickets.