Opened 6 years ago

Closed 5 years ago

#122 closed System Defect (worksforme)

GUI fails on Lenovo Z60M

Reported by: Hopkins Owned by:
Priority: blocker Milestone:
Component: XOrg Configurator Version: 1.5
Keywords: display corruption z60m lenovo x600 boot Cc:

Description

I am attempting to install PC-BSD on a Lenovo Z60M featuring an ATI X600 mobile graphics card and a 1680x1050 display. The installation appears to be succesful, however when the OS first boots the screen is corrupted. I can see that it has tried to draw the PC-BSD wallpaper and I can take a photograph of this corruption later today if that would be helpful. The mouse pointer is visible and active, but it cannot interact with anything.

I'm afraid that I have no experience of BSD, and limited exposure to *nix OSs (a year of two of Ubuntu Desktop, that's all!).

I broke into the bootup process and tried fiddling with xorg.conf but I wasn't allowed to save the changes, even after running "su root". Clearly I am lacking some key knowledge here!

I will try to help if you can instruct me.

Many thanks!

Change History (4)

comment:1 Changed 6 years ago by Hopkins

PS: I hadn't noticed this before, but apparently my problem is similar to this one:

http://trac.pcbsd.org/ticket/119

I will try 1.4.1 soon and report back.

comment:2 follow-up: Changed 6 years ago by Hopkins

I tried installing from the 1.4 images. In this case, I did not receive a corrupt screen, but the GUI still did not finish booting. I tried the display setup boot option again but with no luck. I'm afraid that I didn't spend any more time trying to diagnose it.

For your information, I also tried Desktop BSD 1.6 which took a slghtly different approach. Firstly, it tried to boot all the way to KDE from the installation DVD. Secondly, it attempted a series display configuration attempts which all resulted in display showing an uncorrupted screen with a responsive mouse pointer, but then some kind of error was reported to the OS and another mode was tried. All failed, and the only option left was to retry the tests (with the same result) or drop to the command prompt. The error messages scrolled by too quickly for me to read them.

I'm going to go with the new Ubuntu release in a couple of days, but good luck with this and I'll certainly pop back in the future.

comment:3 in reply to: ↑ 2 Changed 6 years ago by yerenkow

Could you check this Issue now, with PC-BSD Beta2?
ftp://ftp.pcbsd.org/pub/beta-isos/i386/

comment:4 Changed 5 years ago by kris

  • Resolution set to worksforme
  • Status changed from new to closed

If you can re-confirm this issue on 7.1.x or higher, please let us know. The xorg drivers have gone through a lot of updates since this bug was opened and should be fixed now.

Note: See TracTickets for help on using tickets.