Opened 7 years ago

Closed 6 years ago

#123 closed System Defect (fixed)

using custom disk partitions causes newfs to skip/fail during install

Reported by: mrezny Owned by: kris
Priority: major Milestone: 7.1.1
Component: Installer Version: 1.5
Keywords: Cc:


This is actually with the new 1.5.1 installer, but there is no option for that version on the ticket. I have not tried 1.5 as I do not have the ISOs and do not see them easily available as the legacy version is 1.4.1.

My system is an old Dell PowerEdge? 2400 server, dual P3-600 with 1GB ECC SDRAM. I've disabled onboard RAID and removed the SCSI backplane to make way for IDE cabling. I installed an old 160GB ATA/133 drive and connected it to a HPT368 based UDMA66 capable PCI card because there are no IDE headers on the motherboard. Still has a SCSI CD-RW for booting the install disc. Interestingly, the ATA controller must be in the single 32bit slot in the system as putting it any of the 64bit slots causes all attempts to access the drive to fail, but that is a FreeBSD driver problem (works in Linux, so not a hardware issue).

When I get to the drive selection in the install, I choose to use entire disk, not install the bootloader, and to customize the partition layout. On the disc partition setup screen, I can choose to use encrypted swap space without any adverse effects. However, if I choose to customize disk partitions in order to crank swap up to match physical RAM, the install ultimately fails. If I don't touch this, the install proceeds correctly.

In the working case, the install progress starts with fdisk /dev/ad0 and then newfs /dev/ad0s1 (shouldn't that be ad0s1a really?), and then proceeds to copy a whole mess of files. In the failure case, the install starts with fdisk /dev/ad0, then quickly flashes by and begins the copy, effectively installing to the md0 backed root which quickly fills. I can't tell if the newfs step is totally skipped, or if it attempts and fails since it goes by so quick. When the files are vfailing to install, the messages resemble those reported in ticket #79. Also, the install is claimed successful at the end, but rebooting results in a Operating System Missing error.

I tried working around my problem by booting to the emergency console and creating my own partitions and file system with bsdlabel and newfs. Unfortunately, the installer has no way to use these. Choosing a Upgrade/Repair? shows no available PCBSD installs. Choosing a Fresh Install forces writing of a new bsdlabel created by the installer, which then fails to properly run newfs.

Change History (2)

comment:1 Changed 6 years ago by yerenkow

  • Milestone set to 7.2
  • Owner set to kris

Seems to be a similar to bug I reported via email.

comment:2 Changed 6 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in 7.x now.

Note: See TracTickets for help on using tickets.