Opened 7 years ago

Closed 7 years ago

#21 closed System Defect (duplicate)

Installer cannot write any files to disk, can partition however

Reported by: kad77 Owned by: tim
Priority: critical Milestone:
Component: Installer Version: 1.4
Keywords: error advanced parition Cc:

Description

http://reviews.cnet.com/motherboards/asus-a8v-vm-motherboard/4507-3049_7-32071665.html?tag=sub

On Asus A8V-VM motherboard, PC-BSD 1.4rc1 install CD will boot to X, run installer and let initial setup steps commence. It will partition the blank 15gb IDE HD, however, during the entire install progress bar each file name is followed by: "cannot write (whatever) no space on disk".

After a few thousand of these, the installer halts with "An error occurred while extracting system image! System will reboot" etc. After reboot, the partition table was written but HD is otherwise blank.

The installer needs better error handling, it kept plodding through this same critical error from 0% to 100%. Also, if PC-BSD installer can write a partition table that is visible after reboot, why can't the installer manage to write a single file from CD to HD??

The CD drive and HD look to be PIO mode 4 from kernel messages, so something in this chipset may not be 100% supported.

Change History (8)

comment:1 in reply to: ↑ description Changed 7 years ago by kad77

  • Keywords advanced parition added; unexplained removed

Followup:

This bug occurred after a simple custom partition selected via GUI installer ( 2GB swap, the rest for root '/' partition).

Selecting 'Use entire disk' checkbox without specifying the extra swap space I desired allowed the install without earlier buggy behavior.

At this point, this ticket likely has more to do with the behavior of the installer (in regards to either sanity checks of the partition layout selected, arguments passed to fdisk, etc) than anything hardware specific mentioned above.

comment:2 Changed 7 years ago by tim

  • Owner set to tim
  • Status changed from new to assigned

comment:3 follow-ups: Changed 7 years ago by tim

Just tried to reproduce your problem, alas to no avail. Tried setting 2GB of swap, and 13GB for / (to simulate your 15GB HD), and chose not to install to the entire disk.

Are you able to reproduce this problem on your machine? If so, please let me know of any steps you missed out. If I can't reproduce the error, it's very difficult to fix.

comment:4 in reply to: ↑ 3 Changed 7 years ago by kad77

Replying to tim:

Just tried to reproduce your problem, alas to no avail. Tried setting 2GB of swap, and 13GB for / (to simulate your 15GB HD), and chose not to install to the entire disk.

Are you able to reproduce this problem on your machine? If so, please let me know of any steps you missed out. If I can't reproduce the error, it's very difficult to fix.

Ok, I have been building a kernel and working on that particular drive, but will try to reproduce on a separate HD on the same machine. I will write down all the steps this time. ;-)

comment:5 in reply to: ↑ 3 ; follow-up: Changed 7 years ago by kad77

Replying to tim:

Update: Using Maxtor 60gb drive

Fresh Install option path

Use entire disk - not checked
Customize partition layout - checked

Next Screen - Disk Partition setup

Customize disk partition - checked

Initial state:
/dev/ad0s1a / 58107MB UFS
/dev/ad0s1b SWAP 512MB UFS

Selected '/' partition, clicked edit, downsized by 1536MB to 56571MB
Selected 'SWAP' partition, clicked edit, sized up to 2048MB

After clicking next a couple times, I saw fdisk and newfs run, and install went ok.

---

The only other issue that may have interfered earlier, was that I had the 15gb IDE drive setup with the "master" pin jumpered when it was the only drive on that IDE channel. I moved the jumper to Cable Select position (and also skipped the custom partitioning. It worked).

This 60gb drive is a few years newer, and by a different manufacturer. The jumpers just allow for Master/Single? ON or OFF (for slave). Over the years, usually an incorrect jumper will cause delays or errors in POST, which did not occur. Sorry I left this out.

Nonetheless, the partition table was written on the 15gb drive. 'newfs' and 'fdisk' could not run apparently, and the installer did not "catch those exceptions". I did not see them execute in the installer dialog for more than a split second during the error I experienced, while they ran for a noticable amount of tiem when installation was normal.

Maybe the goal of reporting this behavior should be to ensure that the installer is checking the exit status or output of the partitioning tools before continuing to attempt to install when a partition is unwritable?

I can backup and wipe the 15gb and try to narrow it down to the jumper or the disk if wanted.

comment:6 in reply to: ↑ 5 Changed 7 years ago by kad77

Replying to kad77:

Replying to tim:

Update: Using Maxtor 60gb drive

Well, messing around with this same 60gb on another machine (the machine in ticket #20), I was able to get the original error again!

Again, I did fresh install. I selected custom parition. Instead of subtracting, and exactly downsizing the '/' partition by 1536MB, I used the slider, and used around ~3gb less. I then upsized SWAP to exactly 2048MB, and then edited '/' again, and moved the slider to max.

I selected a bunch of packages from CD2, and proceeded to install. Instead of seeing fdisk and newfs run for any noticeable amount of time, the installer is spitting out line after of line of 'cannot write (this) to /' and 'failed to create'.

I've reproduced this on two unique machines now. Hope this helps!

comment:7 Changed 7 years ago by andrei

  • Priority changed from major to critical

Same problem with 1.4 release- installed using whole disk and custom partitioning. "An error occured while extracting the system image! Please check the install CD, ....."

No error messages or whatsoever in dmesg and filesystem is clean.

comment:8 Changed 7 years ago by tim

  • Resolution set to duplicate
  • Status changed from assigned to closed

The problem has been tracked down to an issue with tar itself. For some reason it isn't playing nice with extracting to multiple partitions.
We'll look into it for the next release, possibly moving to another extraction method, 7zip?

Although not obvious, this ticket is actually a duplicate of #17, just slightly different symptoms, so I'm marking it as such ;)

Note: See TracTickets for help on using tickets.