Opened 5 years ago

Closed 5 years ago

#233 closed System Defect (fixed)

8.0-RC: Country or Region in KDE System Settings is set wrongly for Slovenia

Reported by: JLP Owned by:
Priority: minor Milestone:
Component: System Configuration Version: 8.0-BETA
Keywords: Cc: trac-bugs@…

Description

I just installed PC-BSD 8.0-RC (AMD64) and during the installation I selected the Slovenian language. The installation was fine but after booting to the desktop I noticed that some data wasn't shown in Slovenian way (translations were fine). I opened System Settings → Country/Region? and Language and there I've noticed that Country or region was set to Sierra Leone, while it should be Slovenia. I guess the problem is that somewhere during the installation you set country in the same way as language, meaning you use SL for country (which is the code for Sierra Leone) while the correct code for country Slovenia is SI. Note: Our language is Slovenian and for this the correct code actually is SL which is set correctly.

Maybe the same mixup with codes is also the reason why Firefox doesn't by default use Slovenian locale and language (sl-SI, which I had to change manualy), and why OpenOffice?.org isn't using Slovenian translations. maybe there is some other problem somewhere else but I didn't notice it or check it out yet.

Change History (1)

comment:1 Changed 5 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

That was easy enough to fix :) Changed it to sl_SI for LOCALE, and set country to "si" as well

Note: See TracTickets for help on using tickets.