Opened 4 years ago

Closed 2 years ago

#306 closed System Defect (fixed)

Cannot boot from mirrored zfs setup

Reported by: billksun Owned by: kris
Priority: major Milestone: 8.1
Component: Installer Version: 8.1
Keywords: disklabel, awardbios, phoenix, hang, post Cc: trac-bugs@…, diddledan@…

Description

Attempting to install the AMD64 disc onto an AMD Athlon X2 system with 4GB of RAM:

I have 2 750GB disks, ad8 and ad10. In the installer, I created a 4 GB SWAP partition on ad8, then setup the rest as mirrored zfs pool with ad10 added into the pool and mounted the pool on "/".

The installation went fine, but upon restart the computer would halt at the POST screen where it displays the HDDs detected, all CDROM and HDDs were detected and displayed, but the boot process is frozen at this point. This screen also displays the text that tells the user to press "ESC" to load the boot menu, or "DELETE" to enter the BIOS.

I then tried a different partitioning setup, where both disks have a 2GB SWAP partition, and the rest of the free space on ad8 is set as ZFS pool with ad10 added into it and mounted on "/". This configuration results in a "permission denied" error when creating the SWAP on ad10.

Scrolling back on the log shows that the boot records were created using pmbr. I saw that in changeset 6766 (http://trac.pcbsd.org/changeset/6766/) that this was supposed to be updated to use gptzfsboot only, I suspect that this could be the reason why my disks were not bootable even after a successful install using the first partitioning setup.

Attachments (1)

boot-hang.JPG (204.4 KB) - added by billksun 4 years ago.
Hanged at this screen when booting 8.1 RC1

Download all attachments as: .zip

Change History (13)

comment:1 follow-up: Changed 4 years ago by kris

Our installer is basically doing the standard GPT / zfs mirror setup as described here:

http://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/Mirror

When doing a similar setup here in virtualbox, it boots just fine. Does your motherboard support GPT / EFI setups?

Another option would be to boot the installer, and then use the +/- buttons on the disk screen, to remove all the partitions, then create some traditional primary MBR partitions. With ad10s1 and ad8s1 in place, you can then go to the advanced screen and setup your custom layouts / mirroring for each. That may let the system boot if there is no bios update to fix GPT/EFI booting for your system.

comment:2 in reply to: ↑ 1 Changed 4 years ago by billksun

Thanks Kris, it didn't occur to me that my motherboard was too old (BIOS dated back to 2005). I guess I just didn't pay attention when all this GPT/EFI thing emerged.

I'll try out the alternative option that you described and report back.

comment:3 Changed 4 years ago by billksun

Okay, so I tried, but failed. I may be doing something wrong here:

I went to the installer, removed all existing slices from ad8 and ad10, and created ad8s1 slice and ad10s1 slice. Then in the advanced screen I created a 4GB SWAP partition from ad8s1, with the rest as zfs mirror with ad10 added into the pool mounted on "/". Noticed that I wrote ad10, not ad10s1. The zfs config dialog only listed ad10 as an option for inclusion into the pool.

Then in the log I see the following right before the installer returns with a popup that says an error occured. The log didn't record any errors however, but this is what was last written on it:

Running: zpool create -m non -f tank0 mirror ad8s1a ad10p2
[...]
Runnning: zpool set bootfs=tank0 tank0

comment:4 Changed 4 years ago by kris

I'll need you to re-try this on RC1 when its available later this week. This was a syntax error in our backend, which was found and fixed last week.

http://trac.pcbsd.org/changeset/6889

comment:5 Changed 4 years ago by billksun

I retried the MBR method using RC1, this time the installation was successful! However, I was not able to boot up the system. I hang at the same spot as when I installed using the GPT/EFI boot method.

comment:6 Changed 4 years ago by kris

Can you send over a picture of the hanging screen, or the text? That'll help me in figuring out at what point the failure is occurring, and whom to bug about it :)

Changed 4 years ago by billksun

Hanged at this screen when booting 8.1 RC1

comment:7 Changed 4 years ago by billksun

Here's the screen shot:
Hanged at this screen when booting 8.1 RC1

The same set of disks used to boot Kubuntu 9.10, and I'm currently booting a separate Windows 7 disk on the same computer, so the motherboard should be okay. Pressing DEL or ESC at this point have no effect, it is pretty much frozen.

comment:8 Changed 4 years ago by kris

Humm, that's pretty wild. Have you tried a non ZFS install? I.E. just do a default UFS install on this system? How about ZFS without the mirror then? Does it boot or hang at the same spot?

From the picture it almost seems like the BIOS itself is hanging, don't even see the BSD loader getting started. Have you also tried a regular FreeBSD install on this system?

comment:9 Changed 4 years ago by billksun

Hi Kris,

I have tried zfs without mirror and plain ufs. Both exhibit the same behavior as before. I then tried to install Kubuntu 10.4, and while I can get past the POST screen, I get a bunch of memory related errors when loading the OS.

So I decided that motherboard may be flaky, and upgraded it, along with a new CPU and new memory sticks. Once the upgrade was completed, I was able to boot a mirrored zfs RC1 installation. So I think this confirms that something was wrong with my hardware an not PC-BSD.

Thanks for your help!

comment:10 Changed 4 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Marking this as "fixed" then, glad to hear it was hardware, since it worked just fine here :)

comment:11 Changed 4 years ago by diddledan

  • Cc diddledan@… added
  • Keywords disklabel awardbios phoenix hang post added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 8.1-BETA1 to 8.1

I too am having this issue with stock freebsd 8.0 on the exact same BIOS version, but with a different mainboard. My mainboard is an MSI 975X platinum powerup with base version 6.00PG of the AwardBIOS as shown in the original poster's image above (the version numbering is for the base bios software, and not the version number that the manufacturer gives each iteration of their customisations. - I am using version 7.90 of MSI's Phoenix AwardBIOS-6.00PG-based BIOS for the 975X Platinum Powerup Edition Mainboard.). It would seem the issue is with the BSD disk label (and others: I had an issue with an OSX hybrid GPT+MBR at one stage but that disappeared after some fiddling, and I am unsure the exact combo that was causing the hang.).

After reinitialising the hard drive with a blank MSDOS MBR (by connecting to another machine, or using a USB caddy to connect _after_ the POST) I can get the boot sequence to proceed normally once the drive is reconnected to the system. However, once the BSD disklabel is back in place the system will hang on the POST screen once again.

The similarity between BIOS type would suggest to me that the issue is with interactions between the disk format and this BIOS and could be affecting many more people than is realised.

I have reopened this bug, however I believe the issue is with core freebsd and not specific to PC-BSD, so feel free to close again.

comment:12 Changed 2 years ago by joshms

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.