Opened 4 years ago

Closed 4 years ago

#338 closed System Defect (fixed)

System Upgrade fails during uninstall phase

Reported by: gschultz Owned by: kris
Priority: major Milestone:
Component: Installer Version: 8.1
Keywords: Cc: trac-bugs@…

Description

System:
AMD64 / 2GB RAM / Sun Workstation

Fault during upgrading from DVD-Full-Install release
During the first step, the system removes packages. The system in question hangs when the linux-package is tried to be removed, so that only a reboot will solve the issue.
As an upgrade is not possible, a full installation is required.
This behavior could be monitored since release 7.1.
Unfortunately no logs could be safed.

Attachments (1)

patch-functions-upgrade.diff (984 bytes) - added by bjoe 4 years ago.
A patch for functions-upgrade.sh

Download all attachments as: .zip

Change History (5)

comment:1 in reply to: ↑ description Changed 4 years ago by harry

Fails for me too (upgrade from 8.0). Complete freeze of mouse and keyboard during Uninstalling packages: linux-f10-atk-1.2.4.0

System: Intel Pentium 4. IDE DVD-RAM (the DVD wouldn't work in the older DVD-ROM drive.

The ISO's md5 checks out, and (the first time I tried) I said yes to the installer verifying itself.
I chose to install all the options (Firefox, openoffice, etc)

Looks like restoring 8.0 or clean installing 8.1 are my options.

Changed 4 years ago by bjoe

A patch for functions-upgrade.sh

comment:2 follow-up: Changed 4 years ago by bjoe

The problem is the linux.ko

The pc-sysinstall mount all the file systems described in the existing fstab. Also linprocfs. Linprocfs provided by linprocfs.ko. This kernel modul loaded automatically and depends on linux.ko. This modul loaded automatically too. Both loaded in a chroot enviroment from the old partition (8.0 PC-BSD) in the new kernel (8.1). When unistalling a linux packages the "linux binary/kernel modul execute" and this result in a kernel panic.

A quick solution:
Befor start the update comment out the "linprocfs" line in /etc/fstab. During the update process there some error messages like "ELF binary type unknown" on the terminal Alt+F1. After the upgrade activate the "linprocfs" line.

I think there is two options to fix the problem:
Fix the pc-sysinstall/backend/functions-upgrade.sh. Appends a "-t nolinprocfs" on the chroot ${FSMNT} /sbin/mount -a line (Look in the patch).
Or
Include the linux.ko with linprocfs.ko in the "installer" kernel (here 8.1).

comment:3 in reply to: ↑ 2 Changed 4 years ago by bjoe

Replying to bjoe:

... When unistalling a linux packages the "linux binary/kernel modul execute" and this result in a kernel panic.
....

More specific:
/compat/linux/sbin/ldconfig -r /compat/linux execute by uninstalling a linux package in the wrong linux kernel modul and this result in a kernel panic.

comment:4 Changed 4 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the patch! I've committed it now, and it should be in the next 9 snapshot :)

http://trac.pcbsd.org/changeset/9190

Note: See TracTickets for help on using tickets.