Opened 4 years ago

Closed 4 years ago

#373 closed System Defect (fixed)

Cannot update phonon-gstreamer port

Reported by: Charlie_X Owned by:
Priority: major Milestone: 8.2
Component: System Configuration Version: 8.1
Keywords: ports, phonon Cc: trac-bugs@…



I was updating the ports on PC-BSD 8.2 when I hit an error with phonon-gstreamer. I have reported the error with the the BSD ports,, but there is no problem with FreeBSD 8.2 itself. I realise that it isn't always possible to update all the ports of a PC-BSD with portmaster -a but I am surprised at this error. The port maintainer suspects a problem with PC-BSD so I'm filing this as a bug here.

Change History (7)

comment:1 Changed 4 years ago by kris

We aren't doing anything special to the installed ports in PC-BSD, so most likely its a bug related to the order of updating. I run into this from time to time, usually removing / rebuilding the offending port fixes the issue. Have you tried removing glib / rebuilding it?

Also, do you have anything special in /etc/make.conf?

comment:2 Changed 4 years ago by Charlie_X

I haven't adjusted my configuration in anyway.

I have just removed glib and reinstalled it (2.26.1_1, assuming this refers to devel/glib20). Given the whole heap of stuff that gets installed it could be several components. But that wouldn't necessarily explain the differences reported by configure which is definitely not finding what it expects. Any other ports I can try to reinstall?

comment:3 Changed 4 years ago by kris

From your original PR, it looks like you've already updated some ports on the system from the original set shipped with 8.2? How about if you remove all of phonon first, pkg_delete -f phonon\*. Then try to rebuild it again, does that change anything?

comment:4 Changed 4 years ago by Charlie_X

Yes, you're right that some ports were already updated. I have already removed phonon and rebuilt it.

Version 0, edited 4 years ago by Charlie_X (next)

comment:5 Changed 4 years ago by kris

Yea, I really don't know how much help we can give with this. PC-BSD is just FreeBSD with a pre-built set of ports, and our custom utilities and such. We are not doing anything weird to the port builds to cause this kind of problem. It sounds like to me that some related port, or even build tool is out of date, and needs to be updated before this will build properly, but offhand I don't know which that would be. This is part of the reason I don't personally do large port updates like this anymore, too often some part of the upgrade would fail, and I would end up removing half of my installed ports before figuring out which combination was causing the failure :P

In this case the only wild guess I could give is to remove / rebuild cmake, glib/related, and other build tools first.

comment:6 Changed 4 years ago by dlavigne

Is this still an issue with 9.0?

comment:7 Changed 4 years ago by dlavigne

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in 9.0-RELEASE, reopen the ticket if it is not.

Note: See TracTickets for help on using tickets.