Opened 3 years ago

Closed 2 years ago

#377 closed System Defect (fixed)

Installer installs to wrong hard disk

Reported by: socialdefect Owned by: kris
Priority: major Milestone:
Component: Installer Version: 9.0-BETA1
Keywords: wrong disk Cc: trac-bugs@…

Description

Hi,

I've been testing 9.0 Beta for a couple of days now and think I found a bug. First I installed the cd version for I didn't have any dvd's, this went well and everything worked as it should.
When I bought some dvd's yesterday I thought I'd install the 64bit version. Again i ran the installer and did everything exactly the way I did before. Tripple checked if I choose the right hd for the install, wasn't hard since the internal hd was called ada0 and my external drive I wanted to install to was called da0. The sizes of the disks were also correct.

I partitioned the external disk to have a 7G root partition, made a swap of 4G and took 70G for /usr.
This is what I end up with on my internal disk:

/dev/label/rootfs0 74G 384M 67G 1% /
/dev/label/usr0 170G 5.9G 150G 4% /usr

No more signs of Windows, Funtoo, KxStudio? or RHEL nor my data partition, the first PC-BSD install on the external disk has been untouched by the installer. Since I found out post-installation I don't have the install log.

Change History (4)

comment:1 Changed 3 years ago by socialdefect

I did another attempt installing the 64bit dvd. This time I noticed that at boot time the disks are being shown as: da0 and da1. When I reach the partitioner they are called ada0 and da0.

Installed again using the same settings as before, no errors but also no bootloader on the external disk but there is also no valid partition table anymore on the internal disk. I don know what goes wrong here but something does go wrong.....

comment:2 Changed 3 years ago by socialdefect

Sorry, seem to have forgotten to check the 'use entire disk' checkbox.

comment:3 Changed 3 years ago by kris

Did you do a "custom" installation, or just use the auto-partitioning tool and select "Entire Disk" or a single partition? Also, can you send the log from the installed system, /root/pc-sysinstall.log

Thanks!

comment:4 Changed 2 years ago by dlavigne

  • Resolution set to fixed
  • Status changed from new to closed

Closing ticket due to lack of feedback. Please reopen with a copy of pc-sysinstall.log if still an issue on 9.0-RELEASE.

Note: See TracTickets for help on using tickets.