Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#574 closed System Defect (worksforme)

New users: Menu auto-refresh every 4 seconds on LXDE

Reported by: TWiN Owned by: tim
Priority: critical Milestone:
Component: User Manager Version: 9.0-RELEASE
Keywords: LXDE Cc: trac-bugs@…

Description

I installed 9.0 REL (32 and 64) on a new computer, the main user called admin created via the installation program works great.

I opened the user management and created a new user, logged in using LXDE and the main menu refreshes every 4 seconds.

The only way to stop the refresh is to open the terminal and

  • chmod 000 ~/.cache/menus

naturally if I do this, once I restart the computer the menu is empty.

doing a "ps awwx" I was able to catch a /usr/local/libexec/menu-cache-gen process running each time that the menu refreshes.

I tried to killed various processes but I was not able to find the culprit, sometime killing pc-controlpanel and menu-cache fix the problem until the computer restarts, other times there are multiple pc-controlpanel.

While the problem is present, the system update doesn't recognize any updates and it runs extremely slow.

I am able to replicate it every time on different computers and CPU.

I also tried to create 2 different users during the installation, and it works correctly

KDE works without problems

Change History (3)

comment:1 Changed 3 years ago by TWiN

I figure out the issue, it will sounds weird but this is what is happening:

If the username is 7 chars long, the menu refreshes. I have tried on 2 different computers to create an username called "seven77" password "seven77" and the menu started to refresh every 4 seconds.

in my case I use first letter of the name and the last name, and most of the people that work here have a last name of 6 chars, causing the issue.

I will create new users and it will be OK, but I believe that this needs to be patched

comment:2 Changed 2 years ago by joshms

  • Resolution set to worksforme
  • Status changed from new to closed

Hey TWiN. I tried duplicating your issue on an x86 installation and a x64 installation with LXDE and was not able to duplicate the issue. I tried using the exact name you did seven77 and it operated normally for me. We will keep an eye open on this, but for now i'm going to close the ticket since I can't duplicate it. Thanks for your submission!

comment:3 Changed 2 years ago by TWiN

Hello, this has been already fixed with Kris Patch to the menucache program.

Note: See TracTickets for help on using tickets.