Opened 3 years ago

Closed 2 years ago

#595 closed System Defect (3rdpartybug)

rc.conf and wpa_supplicant.conf gets corrupted on configuring network via UI

Reported by: tinca Owned by: kenmoore
Priority: major Milestone:
Component: System Configuration Version: 9.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Reported on the forum for 9.0 beta:
http://forums.pcbsd.org/showthread.php?t=15063
the problem still persists.
I had one working wireless entry and wanted to make another for an other network when confronted with the issue again.
Its a serious defect for those who knows little about computers and/or FreeBSD in general.

Change History (7)

comment:1 follow-up: Changed 3 years ago by kenmoore

  • Owner set to kenmoore
  • Status changed from new to assigned

Can you list the steps to reproduce this? I have added/removed many different wifi access points and cannot get your results. In fact, we even changed some of the background code for 9.0 to prevent *.conf file corruption, so I need a bit more info to track down at which step the corruption is happening to see if that step is using the new code.

comment:2 Changed 3 years ago by obo

Just quick note, details will follow. Any hints of which additional logs to check is welcome.

I have the same problem on Lenovo S10e - and my wifi is also using bwn driver.

Steps to reproduce are very easy: open the UI and click Apply after ANY change (even not changing any wifi related things will cause the issue). This will immediately freeze the OS completely (hard reset needed) and after reboot, rc.conf is empty. It does not affect wpa_supplicant.conf (so in my case, non-empty wpa_supplicant.conf is not corrupted).

Fresh installed rc.conf contains both bwi and bwn (and accompanying siba_bwn and firmwares v3, v4), leaving only bwn (and siba_bwn and bwn_v4_ucode) does not solve the issue.

What I also found is that UI is not reading existing wpa_supplicant.conf (I have manually configured wpa_supplicant and rc.conf to have wifi working) - so my running wifi configuration is not visible in the UI.

/var/log/messages does not show anything abnormal.

Current behavior also exposes a problem where UI is modifying a file but, in fact, I have not found any backup copy of it anywhere.

I will send obvious logs (messages, ifconfig, wpa_supplicant, etc.) later. Is there any specific log which can provide more details of what the network UI is doing?

comment:3 in reply to: ↑ 1 Changed 3 years ago by tinca

Replying to kenmoore:

Can you list the steps to reproduce this? I have added/removed many different wifi access points and cannot get your results. In fact, we even changed some of the background code for 9.0 to prevent *.conf file corruption, so I need a bit more info to track down at which step the corruption is happening to see if that step is using the new code.

Sry for not answering this, I got no notification about your comment, unlike obo's.
If the things obo described are not sufficient, I'll try to reconstruct the scenario.
I am going to follow this ticket for some time.

comment:4 follow-up: Changed 3 years ago by obo

OK, I just spend 4 hours trying to reproduce the bug again. Apparently no success. What I did today:

  1. Installed fresh PCBSD9 from full USB image with GNOME only.
  2. GNOME network manager is lost and does not show any configuration details.
  3. Configuration through PCBSD control panel worked ok (first add bwn0 as interface, then adds wlan0 together with config of AP what create wpa_supplicant.conf).

So this way is ok - we can at least say that full configuration from PCBSD control panel works.

I am suspicious that the bug popped two days ago due to me playing with other window managers (I switch from LXDE to KDE to GNOME and did some network settings through their tools).

Will keep you posted.

comment:5 in reply to: ↑ 4 Changed 3 years ago by kenmoore

Replying to obo:

OK, I just spend 4 hours trying to reproduce the bug again. Apparently no success. What I did today:

  1. Installed fresh PCBSD9 from full USB image with GNOME only.
  2. GNOME network manager is lost and does not show any configuration details.
  3. Configuration through PCBSD control panel worked ok (first add bwn0 as interface, then adds wlan0 together with config of AP what create wpa_supplicant.conf).

So this way is ok - we can at least say that full configuration from PCBSD control panel works.

I am suspicious that the bug popped two days ago due to me playing with other window managers (I switch from LXDE to KDE to GNOME and did some network settings through their tools).

Will keep you posted.

This makes it sound like you were initially using some other network configuration utility (such as from the installed desktop environment) that caused the bug to occur, but if you only use the PC-BSD tools instead it seems to work fine.
Is this a fair summary? If so, it might be an error in the porting of that DE's network utilities to FreeBSD rather than a problem with our PC-BSD network utilities.

comment:6 Changed 3 years ago by obo

It works at least with GNOME and PC-BSD tools only. That is fair summary.

I will try to check it with LXDE (at least) to see whether I can reproduce the bug on that WM.

comment:7 Changed 2 years ago by kenmoore

  • Resolution set to 3rdpartybug
  • Status changed from assigned to closed

Closing this ticket as a 3rd party bug since it appears that only using the PC-BSD tools will prevent this error from happening.

Note: See TracTickets for help on using tickets.