#705 closed Feature Request (wontfix)

Qt apps shall respect desktop style settings

Reported by: mjollnirpaul Owned by: Kris
Priority: trivial Milestone:
Component: System Configuration Version:
Keywords: KDE, Qt, desktop style Cc: trac-bugs@…

Description

The Qt style is set fixed to QtCurve?.
(Partial) Fix: in qtconfig-qt4, set style to "Desktop Settings (Default)". Unfortunately, the scrollbars are ugly and not like in KDE, but that's not very important.

This should be system-wide default, for new accounts, too, and I do not know how to do that, i.e. may be port comes w/ the wrong preset.

Change History (2)

comment:1 Changed 11 months ago by joshms

  • Owner set to Kris

comment:2 Changed 10 months ago by kris

  • Resolution set to wontfix
  • Status changed from new to closed

This is by design. We use QTCurve as the default them for GTK apps as well, in order to provide a more "uniform" look-n-feel when running apps in any desktop. You are welcome to change the defaults on your box, but by default I plan on leaving it QTCurve. Once GTK3 stuff begins hitting the ports tree, we may revisit this and see what looks best.

Note: See TracTickets for help on using tickets.