#738 closed System Defect (fixed)

installer would not work with custom partitioning

Reported by: sara Owned by: kris
Priority: major Milestone:
Component: Installer Version:
Keywords: customize partion disk installer Cc: trac-bugs@…

Description

Choosing custom for the disk partitioning would cause the install to fail, the disk layout, /, /tmp, /home..., gets deleted after finishing the options and if I proceed the installer fails with no / root partition. I had to use the defaults. Also it seems to be using grub? I wanted gpt.

FreeBSD pcbsd-256 9-STABLE-p2 FreeBSD 9-STABLE-p2 #13 r+b03fa54: Fri Jul 19 18:33:11 EDT 2013 root@avenger:/usr/obj/pcbsd-build64-stable/fbsd-source/src/sys/GENERIC amd64

Attachments (3)

pc-sysinstall.log (68.1 KB) - added by sara 13 months ago.
pc-sysinstall.cfg (1.2 KB) - added by sara 13 months ago.
Desktop.txt (35.6 KB) - added by sara 13 months ago.

Download all attachments as: .zip

Change History (5)

Changed 13 months ago by sara

Changed 13 months ago by sara

Changed 13 months ago by sara

comment:1 Changed 13 months ago by sara

I discovered the problem is with noatime, the gui lets me set noatime on / at the top which breaks the script. Going back and choosing basic resets the partition list to be made. Going back through advanced and setting noatime on all but the first entry works.

Also while in the installer environment I couldn't find some of the documentation like the readme for custom install scripts to help me figure this out.

The compression options also don't list lz4, but the zfs supports it.

comment:2 Changed 13 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

The noatime issues will be fixed in the most recent -STABLE ISOs. I've also added lz4 compression to the GUI now:

https://github.com/pcbsd/pcbsd/commit/c8c7b0d3480c0a91750dba60f4c62dc79069cf3b

Note: See TracTickets for help on using tickets.