#739 closed System Defect (deferred)

Installer from usb is not setting the boot options correctly.

Reported by: sara Owned by: kris
Priority: major Milestone:
Component: Installer Version:
Keywords: 9-STABLE-p2 grub gpt installer bootloader Cc: trac-bugs@…

Description

I did my first install and grub was used. I could not get the bsd bootloader to install because I could find no option for it in the gui. After messing up the system I reinstalled with gpt, but there was no option I could find not to use grub. Also there was no indicator that grub would be used.

When the installer finished this time the next system boot stopped on grub and had a message that something was missing with a number that looked like an uuid. Grub left me at a command prompt, "rescue>", that only had one working command from my random tries to find anything that worked. ls worked and showed me hd0. boot, help, cd, ?, etc..., nothing else worked. I booted up the installer from the usb image and opened a terminal and manually removed ada0p1 and replaced it with the standard pcbsd bootloader using gpart and it worked.

Sadly there seemed to be no man files in the installer environment, but luckily I had a smart phone to google the answers with.

PC-BSD 9-STABLE-p2 amd64 INSTALL DVD/USB - Fri Jul 19 19:37:02 EDT 2013

Change History (1)

comment:1 Changed 10 months ago by kenmoore

  • Resolution set to deferred
  • Status changed from new to closed

Please re-test with the latest 9.2 images. The GRUB2 implementation within the installer has gone through a large number of changes, one of which is that you should now be able to install the PC-BSD GRUB2 into the same partition as the install rather than the MBR if desired.

Note: See TracTickets for help on using tickets.