Opened 9 months ago

Closed 6 months ago

#742 closed System Defect (fixed)

PCBSD9.1-RELEASE-x64-USB-live-latest.img kernel panic

Reported by: lmf Owned by: kris
Priority: major Milestone:
Component: Installer Version: 9.1-RELEASE
Keywords: kernel panic on 9.1 USB-live Cc: trac-bugs@…

Description

Booting PCBSD9.1-RELEASE-x64-USB-live-latest.img results in kernel panics on both Lenovo X1 Carbon and Dell Optiplex 755. FreeBSD 9.1-RELEASE-amd64-memstick.img boots correctly on the Lenovo, so I'll file this as a PC-BSD bug.

The downloaded .bz2 md5sum is correct: MD5 (PCBSD9.1-RELEASE-p15-07-19-2013-x64-USB-live.img.bz2)= 6d7880e4d2916c603f3968d736fbd229. The unzipped size = 5930573824. I wrote the image to two different USB sticks (one 8G, one 32G), both using dd on a FreeBSD 8.2 host.

The Lenovo X1 is running Windows7. Setting BIOS to Legacy and disabling USB 3.0 didn't help. The Dell is running some recent Linux.

Since it's a kernel panic on boot, there's no sysinstall log, etc. Actually, I don't know how to sensibly capture a kernel panic on an installer. (Setting dumpdev to swap wouldn't work, nor would remote gdb, esp. if the problem is in USB drivers...) The Dell pauses and shows the kdb_backtrace, but the Lenovo doesn't. I took video of the screen and stepped through it to capture the panics.

Dell Optiplex 755: Current process = 15 (usbus2); trap number = 12; panic: page fault. The relevant bit of the stack trace seems to be if_alloc+0x71; zyd_attach+0x1ba; device_attach+0x72; usb_probe_and_attach+0x1f9.

Lenovo X1 Carbon: Current process = 15 (cdce0); trap number = 12; panic: page fault. The relevant bit of the stack trace seems to be if_alloc+0x71; ue_attach_post_task+0x9a; usb_process+0xd3.

I can make the video available (files are large) and am willing to spend a little time on this before defaulting back to FreeBSD install. (The Dell isn't my machine, I just used it briefly to try to isolate the problem, so I can't debug further there.)

Change History (1)

comment:1 Changed 6 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

This looks like an issue with the VIMAGE kernel module. It was removed for the last set of 9.2-RELEASE ISO's, can you re-test with that? If it still fails, please re-open the ticket.

Note: See TracTickets for help on using tickets.