#777 closed System Defect (3rdpartybug)

USB Mice are not reconnecting after unplugged / using USB switch

Reported by: joshms Owned by: kris
Priority: major Milestone: 9.2
Component: System Configuration Version: 9.2-RELEASE
Keywords: 9.2, USB, Mouse Cc: trac-bugs@…

Description

Users Bforest and AN00B are reporting that USB mice are not working after being unplugged and / or switched using a USB switch. I have confirmed this on 2 PC-BSD test systems as well. Can you look at this and determine if this is something we can fix? If it is driver related I will forward it over to FreeBSD.

http://forums.pcbsd.org/showthread.php?t=20985

Change History (2)

comment:1 Changed 13 months ago by bridger

Hi all,
I've noticed similar behavior: unplug my USB keyboard and the USB mouse dies, replug the keyboard and I couldn't get the mouse to come back without a reboot.

Thanks,
Bridger

Version 0, edited 13 months ago by bridger (next)

comment:2 Changed 13 months ago by kris

  • Resolution set to 3rdpartybug
  • Status changed from new to closed

I've done some checking into this and it looks like a bug in HAL. (The console mouse comes back just fine). It seems that HAL isn't passing mouse notify events onto X for some reason. I'm not sure the cause, but I don't plan on doing too much looking into it. HAL is depreciated and we will be removing it in favor of devd events (which do work) on 10.X. If somebody does know of a work-around, please post it back here though.

Note: See TracTickets for help on using tickets.