Opened 10 months ago

Closed 5 weeks ago

#825 closed System Defect (deferred)

wireless icon in tray showing wrong icon

Reported by: joshms Owned by: ken
Priority: trivial Milestone:
Component: Network Manager Version: 10-CURRENT
Keywords: Cc: trac-bugs@…

Description

The wireless tray icon is showing radio waves emanating out when it is not connected, and showing only the antenna and no waves when it is connected. Isn't this logically backwards? :).

Expected behavior: Wireless tray icon shows radio waves emanating when it has a good connection and vice versa for disconnected.

Attached a picture of the icon while wireless is disconnected. I do not use wireless at all on this system because I have it hard wired.

Attachments (1)

disconnectedicon.png (14.9 KB) - added by joshms 10 months ago.

Download all attachments as: .zip

Change History (4)

Changed 10 months ago by joshms

comment:1 Changed 9 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from new to closed

This got worked on by Kris, Josh, and myself and the problem was that his wireless device was getting an additional bogus IPv4 address - and the tray was simply reporting the stats for that IP rather than the one that was actually working.
Kris already discovered the issue and put a fix in place to prevent bogus IP addresses in the future.

comment:2 Changed 7 months ago by joshms

  • Resolution fixed deleted
  • Status changed from closed to reopened

Wireless Icon is still not displaying correctly

Now it shows a "weak signal icon" instead of a "full signal icon". I have 96 - 100% signal.

comment:3 Changed 5 weeks ago by joshms

  • Resolution set to deferred
  • Status changed from reopened to closed

ticket migrated. closing.

Note: See TracTickets for help on using tickets.