#843 closed System Defect (fixed)

Unable to set password with pc-usermanager due to an invalid character

Reported by: shirkdog Owned by: tim
Priority: major Milestone:
Component: User Manager Version: 9.2-RELEASE
Keywords: Cc: trac-bugs@…

Description

Test case:
1)Open up usermanager and add a new user
2)set a username/fullname
3)enter any password with a comma ',' and it will be marked invalid

The problem is in usermanagerback.cpp at line 41

passwordRegExp.setPattern("([a-z]*[A-Z]*[0-9]*[!\"$%^&*()_+=#'`@~:?<>|{}\\-.]*)+");

The regex does not have a comma, therefore validation fails.

Fix:
add a comma into passwordRegExp.setPattern.

Change History (2)

comment:1 Changed 10 months ago by shirkdog

This has been addressed in commit 8ad6faf

comment:2 Changed 10 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.