Opened 4 months ago

Closed 4 months ago

#852 closed System Defect (invalid)

Warden autoadds the user from my host and nullfs_mounts its $HOME

Reported by: yggdrasil Owned by: kris
Priority: major Milestone:
Component: Misc Version: 9.2-RELEASE
Keywords: warden user management autoadded host user Cc: trac-bugs@…

Description

Based on my post in the forums:
http://forums.pcbsd.org/showthread.php?t=21391

I have two portjails created with warden. When I start them, the user from my main system gets added as a user to the jail, and my $HOME nullfs_mounted automatically. This might have destroyed my firefox profile (I tested in a portsjail with custom build firefox) and my snapshots of $HOME. When I delete the user in the warden usermanager I expected it to delete the home directory inside the jail, since it is the user manager of the jail. Instead all snapshots of my home dir on my host are deleted.
The user will always be readded and $HOME nullfs_mounted when warden starts the jail.

Change History (2)

comment:1 Changed 4 months ago by joshms

  • Owner set to kris

comment:2 Changed 4 months ago by kris

  • Resolution set to invalid
  • Status changed from new to closed

So, what you describe is what it was designed to do. The portjail is *not* a separate jail from the host, it shares home-dirs and /tmp among others. This is to allow you a sandbox for running a different tree of ports / packages, but still use home-dir data.

You may be wanting to use a more "traditional" jail, which won't share anything.

Note: See TracTickets for help on using tickets.