Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#856 closed System Defect (fixed)

trueos hangs on every reboot

Reported by: tolkor Owned by:
Priority: major Milestone:
Component: System Configuration Version: 9.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Got a TrueOS system that hangs on every reboot. It acts like it is performing an upgrade, gets to "Extracting server overlay data... DONE" then sits at the "Press ENTER to continue". I just did a pc-updatemanager check/pkgcheck this morn, still the same thing happening.

Hardware is a Silicon Mechanics box,
CPU: AMD Opteron(tm) Processor 6308 (3500.07-MHz K8-class CPU)

Origin = "AuthenticAMD" Id = 0x600f20 Family = 0x15 Model = 0x2 Stepping = 0
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
Features2=0x3e98320b<SSE3,PCLMULQDQ,MON,SSSE3,FMA,CX16,SSE4.1,SSE4.2,POPCNT,AESNI,XSAVE,OSXSAVE,AVX,F16C>
AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM>
AMD Features2=0x1ebbfff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,XOP,SKINIT,WDT,LWP,FMA4,<b17>,NodeId?,TBM,Topology,<b23>,<b24>>
Standard Extended Features=0x8
TSC: P-state invariant, performance statistics

real memory = 69373788160 (66160 MB)
avail memory = 66430922752 (63353 MB)

Install was default TrueOS install giving these partitions:
# df -h|egrep "tank/"
tank/ROOT/default 913G 2.6G 910G 0% /
tank/tmp 910G 80k 910G 0% /tmp
tank/usr/home 910G 79k 910G 0% /usr/home
tank/usr/jails 910G 31k 910G 0% /usr/jails
tank/usr/obj 910G 31k 910G 0% /usr/obj
tank/usr/pbi 910G 63k 910G 0% /usr/pbi
tank/usr/ports 910G 174M 910G 0% /usr/ports
tank/usr/ports/distfiles 910G 3.8M 910G 0% /usr/ports/distfiles
tank/usr/src 910G 31k 910G 0% /usr/src
tank/var/audit 910G 33k 910G 0% /var/audit
tank/var/log 910G 19M 910G 0% /var/log
tank/var/tmp 910G 32k 910G 0% /var/tmp

Version:
# uname -vis
FreeBSD FreeBSD 9.2-RELEASE-p8 #0: Mon Sep 23 16:26:45 UTC 2013 root@…:/usr/obj/usr/src/sys/GENERIC GENERIC

Attachments (1)

rc (5.0 KB) - added by tolkor 7 months ago.
/tmp/rc

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 months ago by kris

If you hit enter, I assume it continues to boot? Can you check for this file and remove it if it exists?

/var/.freebsd-update-finish

comment:2 Changed 7 months ago by tolkor

Sorry, yes it does boot normally when hitting <cr>.

/var/.freebsd-update-finish exists and is 0 length.

comment:3 Changed 7 months ago by tolkor

Aaaannnd it boots just fine now that the file is rm'd.

Tnx heaps and loads.

comment:4 Changed 7 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Ok, glad that fixed it. Can you attach a copy of your /etc/rc file? Wonder if something is mangled in there.

Changed 7 months ago by tolkor

/tmp/rc

comment:5 Changed 7 months ago by tolkor

Attached.

In the FWIW dept, this has been going on since an upgrade 1 or 2 months ago. I have never brought it up as I was just waiting patiently to see if a future upgrade fixed things. ;>

Tnx again!

comment:6 Changed 7 months ago by kris

Ok, this helps, you have an older bugged version of /etc/rc.... If you run "freebsd-update fetch", does it show any new updates? There should have been a patch to /etc/rc to fix this which went out a while back.

comment:7 Changed 7 months ago by tolkor

Tons. Guess I misunderstood TrueOS. I thought everything was best done through pc-updatemanager. I will do a freebsd-update install.

On a cool note, upgrades to the ix NIC driver showed up. This may fix the problem I'm having where using 2 10Gb ports on the NIC causes all networking to stop. ;> Use one and everything works great. Use 2 and all networking eventually locks up. Tnx much!

comment:8 Changed 7 months ago by kris

No prob! Yes for TrueOS / FreeBSD we use both the "freebsd-update" and "pc-updatemanager" commands to do updates for the world / packages respectively. On the desktop side all of that is managed in the background for you automatically.

Note: See TracTickets for help on using tickets.