Opened 9 months ago

Closed 6 months ago

#862 closed System Defect (fixed)

system updates repeatedly applying the same update

Reported by: hsw Owned by: kris
Priority: major Milestone:
Component: PC-BSD Updater Version: 10-STABLE
Keywords: Cc: trac-bugs@…

Description

System updates are not applying, the process is always showing an outstanding
update on:
10-STABLE-p5 FreeBSD 10-STABLE-p5 #0: Fri Dec 6 02:13:09 UTC 2013 root@…:/usr/obj/usr/src/sys/GENERIC amd64

Running freebsd-update in a terminal shows that the following:

The following files will be updated as part of updating to 10-STABLE-p5:
/usr/share/man/man2/extattr_get_link.2.gz

Repeating the fetch after the install shows the same file to be updated.

I looked at the /var/db/freebsd-update and the /usr/sha/man/man2/extattr*
and it seems as if the update process is just recreating this file as
a hard link. (all the exattr*.2.gz are hardlink to the same man page)

As a final test I rolled back all of the updates until there were no updates
installed, then ran fetch/install, but once this update is reached, the update show the same problem.

Change History (11)

comment:1 Changed 9 months ago by hsw

Some more testing:

  1. rollback then use the graphical updater - goes to the same loop
  1. modified /etc/free-update.conf by adding the line:
    IgnorePaths /usr/share/man/man2/extattr_get_link.2.gz

The system is now showing as up to date, unfortunately pkg is now broken

comment:2 Changed 8 months ago by joshms

  • Owner set to kris

I can confirm. I've had the same update issue. I've reset several times now and it has asked me to apply the same update each time.

comment:3 Changed 8 months ago by kris

So, the new package sets should be out now, along with a freebsd-update to -p6. Are you on -p6 and do you still see this file being requested to update?

comment:4 Changed 8 months ago by hsw

I have Just managed to update to p6. Needed to force install of pkg,

pkg remove -f py27-distribute-0.6.35
pkg install -f pcbsd-utils-qt4

After that the GUI package updater worked and it changed the Linux emulator from c6 to f10.
(Hope that is correct)

However the extattr_get_link update is still present.


I have just done a fresh install on another machine (Compaq 6515b) and the above update
is requesting to be installed again (third time). I checked /var/db/freebsd-update
and can see there are already two installs. Could it a bad entry in the freebsd update server
or perhaps a bug in freebsd-update not recognising hard links that are already present?

I installed the 6515b from PCBSD10-STABLE-p6-12-16-2013-x64-DVD-USB.iso using USB reader + 8GB microSD. card

comment:5 Changed 8 months ago by joshms

Ticket #879 contains additional information.

comment:6 Changed 8 months ago by kris

I'm not seeing this occur on my box here. Whats the output of "ls -al /usr/share/man/man2/extattr_get_link.2.gz" show? On my system it is a hard-link to the same 13 other extattr* files in /usr/share/man/man2/extattr*

comment:7 Changed 8 months ago by malco_2001

I have also been seeing this for a while in 10/STABLE but I've just been ignoring it.

Here is the output for me. It would appear that mine does not show a symlink. Perhaps that is the problem?

[jmaloney@jm-desk-pc] ~% ls -al /usr/share/man/man2/extattr_get_link.2.gz
-r--r--r-- 13 root wheel 2905 Dec 17 15:34 /usr/share/man/man2/extattr_get_link.2.gz

comment:8 Changed 8 months ago by kris

That looks correct... What happens if you remove the /usr/share/man/man2/extatrr* files and then let freebsd-update re-create them?

comment:9 Changed 8 months ago by malco_2001

After removing the ext* files the pcbsd updater said no updates available.

Then I tried freebsd-update fetch

[root@jm-desk-pc] ~# freebsd-update fetch
Looking up fbsd-update.pcbsd.org mirrors... none found.
Fetching metadata signature for 10-STABLE from fbsd-update.pcbsd.org... done.
Fetching metadata index... done.
Inspecting system... done.
Preparing to download files... done.

The following files are affected by updates, but no changes have
been downloaded because the files have been modified locally:
/etc/mail/freebsd.cf
/etc/mail/sendmail.cf
/etc/pkg/FreeBSD.conf
/root/.cshrc
/root/.profile
/var/db/mergemaster.mtree

The following files will be added as part of updating to 10-STABLE-p6:
/usr/share/man/man2/extattr_delete_link.2.gz
/usr/share/man/man2/extattr_get_link.2.gz

Here are the results from freebsd-update install

[root@jm-desk-pc] ~# freebsd-update install
Installing updates...ln: /usr/share/man/man2/extattr.2.gz: No such file or directory
ln:
/usr/share/man/man2/extattr.2.gz: No such file or directory
chflags: /usr/share/man/man2/extattr_delete_link.2.gz: No such file or directory
chflags:
/usr/share/man/man2/extattr_get_link.2.gz: No such file or directory

The ext* files do not get recreated.

comment:10 Changed 8 months ago by hsw

I just tried fresh installs with the latest ISOs:

PCBSD10-STABLE-p6-01-02-2014-x64-DVD-USB.iso - after update of a patch and a large security update
the extattr update is repeatedly requested.

PCBSD10.0-RELEASE-p2-01-02-2014-x64-DVD-USB.iso - I am able to get this to show fully updated.
(rescanned and rebooted to make sure noting is outstanding)

So for me the problem only exists on the stable branch.

comment:11 Changed 6 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from new to closed

I am going to close this ticket as "fixed" by moving to the -RELEASE branch since the 10-STABLE branch is dead for the time being until it gets resurrected in preparation for FreeBSD 10.1.

If you still experience this, please move over to the -RELEASE branch using the "pc-updatemanager" command-line utility.

Note: See TracTickets for help on using tickets.