#873 closed System Defect (fixed)

10-stable graphic install fails to detect hard disk

Reported by: hsw Owned by: kris
Priority: minor Milestone:
Component: Installer Version: 10-STABLE
Keywords: Cc: trac-bugs@…

Description

I just installed a Compaq 6515b from
PCBSD10-STABLE-p6-12-16-2013-x64-DVD-USB.iso using USB reader + 8GB microSD.

After booting to the initial splash screen there was a long delay and
a dialog saying no hard disks were detected appeared. Clicking the OK
appeared to hang the machine, after several minutes I used Ctrl-Alt-Del and it rebooted.

(This also happened on Dell Optiplex 330 with the p5 ISO, have not tried p6
on this one yet)

A reboot was the same; so I tried the text install on the third try.

I selected desktop install, and after a delay it detect the hard disk as ada0
and the USB reader as da0. The ada0 entry was already selected.

There was no option to select the desktop do I edited the installer script to remove all meta-kde and replaced with meta-xfce and meta-xfce-plugins.

The rest of the install was smooth, reboot and initial user creation ok
screen resolution and sound ok; only wifi (bwn0) is not working.

Change History (5)

comment:1 Changed 12 months ago by hsw

I tried the 6515b with PCBSD10.0-RELEASE-p1-12-23-2013-x64-DVD-USB.iso
same result: Unable to detect any disk drives.

I checked that text install still detects ada0 correctly but did not proceed with the install.

I did try the xorg option but noting happens, the vesa optio displays a message for a few seconds
then returns to text menu.

comment:2 Changed 12 months ago by kris

Can you try this?

Boot the ISO file, then when you get to the GUI, right-click the wallpaper and bring up "xterm". Run "pc-sysinstall disk-list" does it return any drives?

comment:3 Changed 12 months ago by hsw

On the 6515b I get:

ada0:Hitachi HTS542525K9A300
da0: <Unknown Device>

It took 41 seconds according to time
(no space after : on ada0 line but has space after : on da0 line)
and detect-laptop returns YES
---
I also ran pc-sysinstaller and just after displaying
system Mem: 5120 it gives an error:
QProcess: Destroyed while process is still running.
Then the unable to detect disk drives dialog is shown.

The same message is also in /tmp/.Sysinstall.log
I did not notice error messages in dmesg or /var/log/messages

comment:4 Changed 12 months ago by hsw

On the Dell it is:

ada0:SAMSUNG HD502IJ
da0: <Unknown Device>

Info from dmesg:

ada0 at ahcich0 bus 0 scbus1 target 0 lun 0
ada0: <SAMSUNG HD502IJ 1AA01112> ATA-7 SATA 2.x device
ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 476940MB (976773168 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4

comment:5 Changed 12 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Ok, that was the issue. The wait time was set to only 30 seconds for "disk-list" to finish. I've bumped it to 90 seconds now, and am going to take a look at how to speed that up as well.

https://github.com/pcbsd/pcbsd/commit/afe80c91465422ed22fae3ee3557cf1b2c2048b7

This change wont be in the next 10.0-RC3 image, but it'll make it into the RC4.

Note: See TracTickets for help on using tickets.