Opened 11 months ago

Closed 11 months ago

Last modified 9 months ago

#877 closed System Defect (invalid)

Clutter render don`t works in the VM machine (Windows 7basic-64bits)

Reported by: anderson Owned by: kris
Priority: minor Milestone:
Component: System Configuration Version: 10-STABLE
Keywords: Cc: trac-bugs@…

Description

/su
/home/adm# gnome-shell –replace
Xlib: extension GLX missing on display 0.0

GModule-CRITICAL :gboolean g_module_close(GModule): assertion ‘module->ref_count> 0‘ failed

Clutter-CRITICAL : Unable to initialize Clutter: Failed to connected to any renderer due to constraints.

Window manager error: Unable to initialize Clutter.

machine: ASUS K45VM core-i7 3610qm/8GiB Ram/750GiB HDD/Geforce GT 630M/windows 7basic 64bits

New and Clear installation

VMWARE settings:
–memory= 4GiB
–HDD= 50GiB
–processors= 6 cores with Intel VT-x ON (virtualize CPU performance counters ON)
–Network adapter= NAT
–3D acceleration graphics= ON
–battery= report ON (works in the Gnome3)

PCBSD options:
–Gnome3
–ZFS= default
–GRUB= ON
–vesa graphics

Attachments (4)

clutter.jpg (187.1 KB) - added by anderson 11 months ago.
clutter
system package manager.jpg (119.7 KB) - added by anderson 11 months ago.
system package
vmware driver.jpg (162.3 KB) - added by anderson 11 months ago.
vmware for gnome3 testing, clutter don't works
1.jpg (197.2 KB) - added by anderson 11 months ago.
system print screen

Download all attachments as: .zip

Change History (16)

comment:1 Changed 11 months ago by malco_2001

When you installed did go to customize at the first screen and did you install the VMWARE guest editions under drivers?

comment:2 Changed 11 months ago by anderson

i didn't customize at the first screen, and didn't install the VMWARE guest (the open virtural machine tools for vmware guest).


now, NEW testing:

The open virtual machine tools for VMWARE guest = INSTALLED!!!

Nvidia drivers = INSTALLED!!! (but only vesa works)

OBS.: in the Windows7/VMware configurations:

VMWARE-virtual machine settings-Options: VMWARE tools features: synchronize guest time with host = ON!!!

TEST RESULT = FAILS (again)

comment:3 Changed 11 months ago by anderson

UPDATE

PCBSD10.0-RELEASE-p1-12-23-2013-x64-DVD-USB

Changed 11 months ago by anderson

clutter

Changed 11 months ago by anderson

system package

comment:4 Changed 11 months ago by joshms

  • Owner set to kris
  • Priority changed from major to minor

comment:5 follow-up: Changed 11 months ago by malco_2001

Anderson did you see my reply to your other ticket? VMware 6 fusion works perfect for me. Gnome shell also launches without the clutter error. What version of VMWare are you running?

comment:6 follow-up: Changed 11 months ago by kris

I'm not sure this is supposed to work. This message here says it all:

Xlib: extension GLX missing on display 0.0

You need a 3d accelerated GLX driver, and the VESA driver you are currently using doesn't support this. You can try the "vmware" driver since you are in a VM, but often that fails also, you may need to run this on bare-metal.

comment:7 in reply to: ↑ 5 Changed 11 months ago by anderson

Replying to malco_2001:

Anderson did you see my reply to your other ticket? VMware 6 fusion works perfect for me. Gnome shell also launches without the clutter error. What version of VMWare are you running?

i didn't see, my apologies.
6.0.1 build-1379776 - VMWARE Player.

my fault, the new version has everything installed:
PCBSD10.0-RELEASE-p1-12-23-2013-x64-DVD-USB
VMWARE guest
Gnome3 (only this)
Nvidia driver (vesa and vmware)

see annex "system package manager.jpg"

Last edited 11 months ago by anderson (previous) (diff)

comment:8 in reply to: ↑ 6 Changed 11 months ago by anderson

Replying to kris:

I'm not sure this is supposed to work. This message here says it all:

Xlib: extension GLX missing on display 0.0

You need a 3d accelerated GLX driver, and the VESA driver you are currently using doesn't support this. You can try the "vmware" driver since you are in a VM, but often that fails also, you may need to run this on bare-metal.

i tested with vesa and vmware driver, now i upload an JPG image for vmware driver and don't works again.

Changed 11 months ago by anderson

vmware for gnome3 testing, clutter don't works

Changed 11 months ago by anderson

system print screen

comment:9 Changed 11 months ago by anderson

PCBSD10-STABLE-p6-12-30-2013-x64-DVD-USB - see JPG image annex (1.jpg "system print screen")

comment:10 Changed 11 months ago by kris

  • Resolution set to invalid
  • Status changed from new to closed

Ok, this is not a bug. I just tested on real hardware with 3d acceleration and it works fine. The thing is, that in vmware you are not using 3d acceleration, the vmware video driver does *not* support it from what I can see.

The GLX error is normal, due to running in a virtual environment without a valid 3d driver.

comment:11 Changed 11 months ago by anderson

ok, was to show that the tip (gnome-shell) did not work in this version.

comment:12 Changed 9 months ago by cabpa

This is solved on my system when I remove all instances of NVIDIA from Package Manager in Basic and Advanced views because I installed all the packages from the installer even I do not have an NVIDIA card.
I am using the VESA driver because the video driver still does not work on my Intel GM45 video card.
So did NVIDIA driver/packages conflicted the system?

Note: See TracTickets for help on using tickets.