Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#911 closed System Defect (fixed)

Installer hangs in black screen

Reported by: gef_f Owned by: kris
Priority: major Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

When the X server is started the second time. The first attempt ends in no screens found error as in other versions. The installer hangs in black screen.

Change History (14)

comment:1 Changed 3 months ago by joshms

  • Resolution set to duplicate
  • Status changed from new to closed

Please see the response to ticket #909. This is pretty much the same issue that X won't start on an optimus based laptop computer so it will be marked as a duplicate.

Thanks for your report!

comment:2 Changed 3 months ago by gef_f

This is a not a duplicate of the 909. The 909 has been there in every 10 version. But this is the first tested version when the second launch of the X server hangs. There were several untested versions between the 10 stable that worked and the RC3.

comment:3 Changed 3 months ago by joshms

I'm sorry, but i'm having trouble understanding. Are you saying in previous versions you (or the installer) were able to restart the x server after the first initial failure and it would work? My 2nd question is you said there were several untested versions that worked...how do you know they worked if they were untested? I'm not trying to frustrate you, i'm just trying to understand the underlying issue here. Please give as much information as possible.

Thanks!

-Josh

comment:4 Changed 3 months ago by joshms

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Just saw your email on the mailing list. I understand now and thanks for the clarification. Can you provide us with full system specs for the sake of documentation? We had some changes to video detection, so I will see if that could have caused an issue with your type of system.

Thanks,

Josh

comment:5 Changed 3 months ago by gef_f

The laptop is X73SV-TY224V from Asus. I have hard time finding datasheets from the net and the laptop didn't come with a manual.

I will try to give some details by hand. Please let me know with if you need more accurate information on specific parts.

CPU: Intel Pentium B940 2.00 GHz
GPU: nVidia GT540M - CUDA 1 GB
RAM: 4 GB
HDD: 500 GB

comment:6 Changed 3 months ago by joshms

  • Owner set to kris
  • Status changed from reopened to new

comment:7 Changed 3 months ago by kris

So I may have fixed this, but to be sure, can you post me the output of this command:

# pciconf -lv

Thanks!

comment:8 Changed 3 months ago by gef_f

I have just tested PCBSD10.0-RELEASE-p3-01-13-2014-x64 and the issue still exists.

comment:9 Changed 3 months ago by kris

In order for me to diagnost / fix, I still need the output of this command:

# pciconf -lv

Can you boot to text-mode and run that for me?

comment:10 Changed 3 months ago by gef_f

comment:11 Changed 3 months ago by kris

Ok, that is helpful. So you have an NVIDIA optimus type setup, with the nvidia card being listed first, and the intel card second. I assume there is no option in the BIOS to enable NVIDIA discrete mode?

In the meantime can you try this and see if it brings up X?

First, boot the installer to text-mode, then go to system-utilities and Shell prompt. Run these commands:

# kldunload nvidia
# startx

If that fails, try again with these commands:

# cp /root/cardDetect/XF86Config.intel /etc/X11/xorg.conf

Then edit /etc/X11/xorg.conf and add this to the bottom:

Section "Device"

Identifier "Card0"
Driver "intel"
BusID "0:2:0"

EndSection?

(You'll be adding the "BusID" section)

Then save the file and run "startx" again. Does that bring up X?

Last edited 3 months ago by kris (previous) (diff)

comment:12 Changed 3 months ago by gef_f

I tested these. One note, the mesg log says it recognizes the Optimus and attempts to use intel. This has been consistent with both working and not working versions.

Test 1 (kldunload nvidia)
This did not work. The nvidia module was not in the loaded modules. However, I tested the opposite and loaded the nvidia module. This did not result in success.

Test 2 (xorg.conf edit)
This did work. I added the BusID exactly as instructed. Started the X. The graphical installer started and I continued and installed the PC-BSD. However, in the first boot, the X server again hangs exactly the same way as in the installer without the xorg.conf edit.

comment:13 Changed 3 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Thank you so much for testing this! That gave me the clues as how to fix it. Please test it again in the upcoming RC5, it should work properly there now.

https://github.com/pcbsd/pcbsd/commit/6569d2b211be2de1fca0d6004a0a375726763227

comment:14 Changed 3 months ago by gef_f

I confirm this is fixed in PCBSD10.0-RELEASE-p4-01-17-2014.

Note: See TracTickets for help on using tickets.