Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#920 closed System Defect (fixed)

Development-IDE meta package is missed

Reported by: yurkis Owned by: kris
Priority: minor Milestone:
Component: Misc Version: 9.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Seems like Development-IDE meta package is broken or just missed:

% sudo pc-metapkgmanager add Development-IDE
Password:
Pending Meta-Package changes: 1
ERROR: No such meta-pkg: Development-IDE

Change History (5)

comment:1 Changed 7 months ago by joshms

  • Owner set to kris

Confirmed also in version 10.0 Stable. Have not tested in release branch.

comment:2 Changed 7 months ago by yurkis

I mean just 10.0-RELEASE-p2 not 9.0. But I have no permissions to change tickets. Please chenge version.

comment:3 Changed 7 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Opps, that was some left-over cruft. Removed it now.

https://github.com/pcbsd/pcbsd/commit/59afe3a7310c10027d31a8d6818e2c7d1fe642cc

If you want a specific IDE, that should be installed via AppCafe?, or another development meta-package, such as Development-Qt if you want designer-qt4.

The IDE category was too vague before, since there are untold numbers of IDEs, and it didn't specify which ones were getting installed.

comment:4 Changed 7 months ago by yurkis

Maybe will be reasonable to add qtcreator to Development-Qt? In any case this is a part of Qt SDK

Note: See TracTickets for help on using tickets.