#937 closed System Defect (3rdpartybug)

Regression, 10-RC2 to 10RC-3. Nvidia Suspend / Resume

Reported by: sim Owned by:
Priority: minor Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: nvidia suspend resume Cc: trac-bugs@…

Description

  • Testing PCBSD 10 on a Thinkpad T510 (i7, nvidia Optimus, but BIOS locked to nvidia only). uname and dmesg attached for ref. *

Suspend / Resume, (acpiconf -s3, from X) appeared to work perfectly on fresh 10-RC2 installation (something I've never seen before on this machine).

After upgrading to 10-RC3 (and later to RC4), "Resume" results in a garbled display. The output appears quite "analogue" - just flickering white streaks on black background - nothing remotely resembling normal output.

More info available on request.

Attachments (2)

dmesg.output (25.2 KB) - added by sim 11 months ago.
dmesg
uname.txt (219 bytes) - added by sim 11 months ago.
uname -a

Download all attachments as: .zip

Change History (4)

Changed 11 months ago by sim

dmesg

Changed 11 months ago by sim

uname -a

comment:1 Changed 11 months ago by sim

By process of elimination:

1) I reverted to RC2
2) I then applied the RC4 upgrade files one by one until the problem occurred.

By this process I can confirm that the resume function works properly after applying ALL RC2->RC4 files changes EXCEPT for kernel.ko. Switching to RC4 kernel.ko causes the "resume" problem to return.

comment:2 Changed 10 months ago by joshms

  • Resolution set to 3rdpartybug
  • Status changed from new to closed

This is unfortunately a FreeBSD issue since it is in the base system. I'd recommend contacting FreeBSD through their problem report webpage http://www.freebsd.org/cgi/query-pr-summary.cgi, although i'm sure they will issue a fix quickly since so many of them are using IBM laptops ;).

Best Regards,

Josh

Note: See TracTickets for help on using tickets.