Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#939 closed System Defect (wontfix)

VM vmware and virtualbox - black screen on Gnome3

Reported by: anderson Owned by: tim
Priority: minor Milestone:
Component: Crash Handler Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

machine:
core-i7 3610qm\8GiB\HDD750GiB\Win7basic 64bits

VM configurations:

mem= 4GiB;
HDD= 50GiB;
Core= 6 for VMWARE - 4 for VIRTUALBOX
GPU= Nvidia GT630M

Clear and New installation.

Desktop - Gnome3

VM driver guest= ON (only VMWARE - not tested in VIRTUALBOX)
SWAP= OFF
GRUB= ON
ZFS= DEFAULT (GPT and 4K = OFF)

Attachments (4)

Gnome3 vmware black screen.jpg (32.6 KB) - added by anderson 11 months ago.
BLACK SCREEN - GNOME3 - VMWARE
freebsdscreen GNOME3.jpg (22.6 KB) - added by anderson 11 months ago.
BLACK SCREEN - GNOME3 - VIRTUALBOX
VBox.log (141.5 KB) - added by anderson 11 months ago.
VIRTUALBOX - LOG
virtualbox settings.jpg (159.9 KB) - added by anderson 11 months ago.

Download all attachments as: .zip

Change History (7)

Changed 11 months ago by anderson

BLACK SCREEN - GNOME3 - VMWARE

Changed 11 months ago by anderson

BLACK SCREEN - GNOME3 - VIRTUALBOX

Changed 11 months ago by anderson

VIRTUALBOX - LOG

Changed 11 months ago by anderson

comment:1 in reply to: ↑ description Changed 11 months ago by anderson

Replying to anderson:

machine:
core-i7 3610qm\8GiB\HDD750GiB\Win7basic 64bits

VM configurations:

mem= 4GiB;
HDD= 50GiB;
Core= 6 for VMWARE - 4 for VIRTUALBOX
GPU= Nvidia GT630M

Clear and New installation.

Desktop - Gnome3

VM driver guest= ON (only VMWARE - not tested in VIRTUALBOX)
SWAP= OFF
GRUB= ON
ZFS= DEFAULT (GPT and 4K = OFF)

PCBSD10.0-RELEASE-p3-01-13-2014-x64-DVD-USB.iso

comment:2 Changed 11 months ago by kris

  • Resolution set to wontfix
  • Status changed from new to closed

I'm pretty sure I've answered this several times now, but here it is again.

The gnome-shell in Gnome 3 *requires* 3d acceleration. The default video drivers for VirtualBox? / VmWare? do *not* do this yet. (Maybe they will at some point, but at the moment no). If you run on bare-metal and have a working driver, such as nvidia / intel / amd, then it runs fine here.

If you plan on using VirtualBox? / Vmware, you should really run another desktop environment.

comment:3 Changed 11 months ago by anderson

yes, I know about 3d acceleration. the issue is that before the screen was not all black, but if says that works out of the virtual machine, ok.

the virtual machine is only for lab tests.

Note: See TracTickets for help on using tickets.