Opened 6 months ago

Closed 6 months ago

#955 closed System Defect (deferred)

Gateway and DNS not working from GUI

Reported by: segfault Owned by: kenmoore
Priority: major Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

I seemed to be unable to set my LAN's DNS server and Gateway server IPs using the Network GUI in KDE.
I was unable to successfully ping the internet until I manually added my DNS settings to "/etc/resolv.conf" and adding "defaultroute="x.x.x.x" to my "/etc/rc.conf".

Once I made these entries manually in the config files and restarted the the "netif" and "routing" services things seemed to work fine.

Change History (3)

comment:1 Changed 6 months ago by joshms

  • Owner set to kenmoore
  • Priority changed from minor to major

comment:2 Changed 6 months ago by kenmoore

Did you use the PC-BSD Network Manager or some KDE network utility?

comment:3 Changed 6 months ago by kenmoore

  • Resolution set to deferred
  • Status changed from new to closed

I am going to close this ticket as deferred ("segfault" can re-open it later if he has additional information).

I just finished going through a major testing session with the PC-BSD Network Manager, and it was changing the configuration files appropriately based upon the GUI settings (like "defaultroute" in rc.conf). We would need additional information about how this bug was caused (the steps you were taking at the time) in order to do any more analysis.

Note: See TracTickets for help on using tickets.