Opened 10 months ago

Closed 9 months ago

#960 closed System Defect (fixed)

Warden GUI does not delete jail and the files.

Reported by: geostar Owned by: kris
Priority: major Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

Warden GUI does not delete jail and the files. Though, Warden in CLI does.

Change History (6)

comment:1 Changed 10 months ago by michi

Hi altogether,

I'm Michael and I would like to take a look at the tickets 960 and 961.
I already discussed that with Kris.
I hope I will be able to contribute to PC-BSD.

Best regards,

Michael

comment:2 follow-up: Changed 10 months ago by michi

Hi geostar,

unfortunately I cannot reproduce the bugs in the two tickets 960 and 961.
Could you please give me more information on how you ran into these bugs?
Do you have a special setup of the warden or PC-BSD itself?
Maybe you even have screenshots? That would be nice!

Another question about the bug where a jail cannot be deleted:
You mentioned that it works using the CLI warden. Have you used any special CL options?
Have you executed the GUI warden as root?

Thank you very much in advance.

Best regards,
Michael

comment:3 in reply to: ↑ 2 Changed 10 months ago by geostar

Replying to michi:

Hi geostar,

unfortunately I cannot reproduce the bugs in the two tickets 960 and 961.
Could you please give me more information on how you ran into these bugs?
Do you have a special setup of the warden or PC-BSD itself?
Maybe you even have screenshots? That would be nice!

Another question about the bug where a jail cannot be deleted:
You mentioned that it works using the CLI warden. Have you used any special CL options?
Have you executed the GUI warden as root?

Yes, while using warden in CLI, as su with root password, I used "warden delete myjail" - that's all :)

Thank you very much in advance.

Best regards,
Michael

Last edited 10 months ago by geostar (previous) (diff)

comment:4 Changed 10 months ago by joshms

  • Owner set to kris

comment:5 Changed 10 months ago by kenmoore

@geostar
Could you run "sudo warden gui" from the CLI as user (give it your user password when prompted), and then re-try deleting a jail?
Once that is done, you should have a bunch of debugging info on the CLI, just paste that here so we can get an idea of what is going on with the GUI when/if you run into the bug.

Thanks!

comment:6 Changed 9 months ago by joshms

  • Resolution set to fixed
  • Status changed from new to closed

closed at user's request.

Note: See TracTickets for help on using tickets.