Opened 8 months ago

Closed 8 months ago

#961 closed System Defect (fixed)

Warden GUI output disappears (quits) after installation of packages inside the jail

Reported by: geostar Owned by: kris
Priority: major Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: warden gui Cc: trac-bugs@…

Description

Warden GUI output disappears (quits) after installation of packages inside the jail. So, one can't verify what was or wasn't installed. Though the packages do get installed. Similar issues during creation of new jail(s) and other configurations, in Warden GUI. Often, the output just quits, but the actions do take effect.

Change History (7)

comment:1 Changed 8 months ago by geostar

Update:
Warden GUI is seriously broken :(

comment:2 Changed 8 months ago by michi

Hi altogether,

I'm Michael and I would like to take a look at the tickets 960 and 961.
I already discussed that with Kris.
I hope I will be able to contribute to PC-BSD.

Best regards,

Michael

comment:3 follow-up: Changed 8 months ago by michi

Hi geostar,

unfortunately I cannot reproduce the bugs in the two tickets 960 and 961.
Could you please give me more information on how you ran into these bugs?
Do you have a special setup of the warden or PC-BSD itself?
Maybe you even have screenshots? That would be nice!


Another question about the bug where a jail cannot be deleted:
You mentioned that it works using the CLI warden. Have you used any special CL options?
Have you executed the GUI warden as root?


Thank you very much in advance.


Best regards,
Michael

comment:4 in reply to: ↑ 3 Changed 8 months ago by geostar

Replying to michi:

In addition to that, I don't understand why and how was local user, with its user password, able to create jail using Warden GUI, which did happen in my case. Tho afterwards, I could not do much with that jail, using Warden's GUI, other than start and stop the jail :)

Update:

While dealing with my other issues, in PCBSD10-RELEASE-p5, I found out that 9.2 and 10 distributions of PC-BSD implemented sudo. So, now I understand how local user, with administrative privileges, can perform system wide configuration, including Warden :)

Moreover, I could not finish testing or try to debug my issues in Warden. Because, my LAN/WAN networking in the PCBSD10-RELEASE-p5, which I was testing, did not work and it will not work with this release of PC-BSD :(

I'll try to continue later with testing of Warden in PCBSD10-STABLE-p7, when I have more free time, since that release had no issues with network configuration and networking, in my system.

So, feel free to close this ticket and the other related ticket #960

Thank you for your help.

geostar

Hi geostar,

unfortunately I cannot reproduce the bugs in the two tickets 960 and 961.
Could you please give me more information on how you ran into these bugs?
Do you have a special setup of the warden or PC-BSD itself?
Maybe you even have screenshots? That would be nice!


Another question about the bug where a jail cannot be deleted:
You mentioned that it works using the CLI warden. Have you used any special CL options?
Have you executed the GUI warden as root?


Thank you very much in advance.


Best regards,
Michael

Last edited 8 months ago by geostar (previous) (diff)

comment:5 Changed 8 months ago by michi

Hi geostar,

thank you for the information.
This will help a lot!

Best regards,
Michael

comment:6 Changed 8 months ago by joshms

  • Owner set to kris

comment:7 Changed 8 months ago by joshms

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.