Opened 6 months ago

Closed 6 months ago

#976 closed System Defect (3rdpartybug)

XFCE and NTFS partition mount issue from desktop

Reported by: gef_f Owned by:
Priority: major Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

When clicking on NTFS partition from internal harddrive on XFCE desktop, it results error message:

mount: illegal option --m usage: mount [-t fstype] [-o options] target_fs mount_point

The same error happens when clicking NTFS partition from external USB harddrive. Same error happens when trying to open partition using MATE Places menu and on LXDE desktop.

Mounting partitions from Mount Tray works correctly.

Change History (1)

comment:1 Changed 6 months ago by kenmoore

  • Resolution set to 3rdpartybug
  • Status changed from new to closed

This is because those DE utilities are trying to use Linux command syntax's for mounting devices (which does not work on FreeBSD). There is no way for us to be able to modify the internals of those utilities, so I am going to close this as a 3rd party bug (contact the appropriate utility maintainer(s) to see if they can either make the mounting routines more cross-compatible or add some FreeBSD routines as well).

The mount tray was written specifically for FreeBSD/PC-BSD and should be used instead.

Note: See TracTickets for help on using tickets.