#977 closed System Defect (fixed)

Opening files from NTFS partitions mounted with Mount Tray fail on some programs

Reported by: gef_f Owned by: kenmoore
Priority: major Milestone:
Component: System Configuration Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

The following programs are unable to open files from Mount Tray mounted NTFS partitions, or even see the contents when traversing the /media/<mount name> with file open dialog.

UMPlayer
Audacious

Following programs can open files under the /media/<mount name>
Leafpad
Emacs

Files can be opened normally after copying them to home folder on installation filesystem.

Change History (8)

comment:1 Changed 10 months ago by joshms

  • Owner set to ken

comment:2 Changed 10 months ago by kenmoore

  • Owner changed from ken to kenmoore
  • Status changed from new to assigned

Ok, just a bit more information please:
1) Did the /media/<something> mountpoint have any special characters in it? (non-letters/numbers)
2) Were UMPlayer and Audacious installed as PBI's or packages?
3) Were UMPlayer and Audacious started up before or after you mounted the device?

comment:3 Changed 10 months ago by gef_f

  1. No special characters. The accurate mount point was /media/DATA/
  2. Both players were installed from AppCafe?. Sorry I didn't realize to mention it when writing the ticket. I'll be sure to mention the install sources in the future.
  3. I have tried both ways and both ways fail.

comment:4 Changed 10 months ago by gef_f

I tested uninstalling audacious and reinstalling it with pkg. If it is installed with pkg it works correctly, it can traverse under the /media/ and open files for playing. So it looks like the issue is somehow related to the way the programs installed using AppCafe?.

comment:5 Changed 10 months ago by kenmoore

I just tested Audacious and it played a *.ogg audio file from a UFS formatted USB stick just fine a moment ago. This might mean it is something related to NTFS mounted devices specifically. There should be a new package update coming out in the next day or two that includes some changes I made to the mount tray to fix some other NTFS device issues, perhaps that will fix your issues as well.

What I think we are seeing though is the effect of FreeBSD switching NTFS support over to the "fuse" kernel modules.

Please let me know if the new package update fixes the problem. I am still looking into this at the moment.

comment:6 Changed 10 months ago by gef_f

I have just tested with the latest update and the problem still exists. Audacious installed from AppCafe? does not see inside the mounted NTFS volume.

comment:7 Changed 10 months ago by gef_f

Additional information. I installed Audacious again with pkg and noticed that there was the same problem of not being able to traverse in the mounted volume or open files, until I installed audacious-plugins.

comment:8 Changed 10 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from assigned to closed

Looks like Kris just fixed it[1].
I just rebuild the pbi-manager on my system to test it, and now I can traverse/use the fuse-mounted devices from within a PBI just fine.

[1] https://github.com/pcbsd/pcbsd/commit/94eae48714ade1fa06a8d431e346326632bd9256

Note: See TracTickets for help on using tickets.