Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#980 closed System Defect (fixed)

Mount Tray gets confused on relogin

Reported by: gef_f Owned by:
Priority: major Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

When mounting a NTFS partition the Mount Tray application on system tray and then logging out and logging in again, the Mount Tray no longer knows the old mounted partition. Instead, it displays the previously mounted partition with new name. It can be mounted, which results the same partition is mounted twice with two different names. The original mount can not be ejected.

Change History (8)

comment:1 Changed 6 months ago by kenmoore

  • Resolution set to deferred
  • Status changed from new to closed

There was a bugfix in the PC-BSD utilities update that went out on Jan 31 that fixes the unmounting of external devices with the mount tray on 10.0
Please update your packages and retest.

comment:2 Changed 6 months ago by gef_f

I believe it got updated yesterday. The bug was noticed today. Is there any way to know what is the update status of the system?

comment:3 Changed 6 months ago by kenmoore

Just open up the package manager (within the PC-BSD Control Panel) and see if there are any package updates available.

I actually did some additional testing with a USB stick earlier and logging out and back in after mounting the USB device did not affect the mounting status or device naming. Once I logged back in it properly recognized that the device was mounted (with the same name and mountpoint) and I was able to successfully unmount it after that as well.

Do you have any special NTFS/device setup on that system that could be causing the issues?

comment:4 Changed 6 months ago by gef_f

This is happening with an NTFS partition (ada0s3) on the same disk where PC-BSD is installed. I didn't test this with external devices. The PC-BSD is installed on ada0s4.

comment:5 Changed 6 months ago by gef_f

  • Resolution deferred deleted
  • Status changed from closed to reopened

I tested with an external USB drive and while it has some weird behavior, it did recognize the drive correctly. So the behavior is different in these cases.

I will use this ticket for the new behavior surprises this test revealed. Unless you think I should create new tickets:

  1. The Mount Tray auto-mounted the drive on first plug in, without the automount being checked.
  1. The Mount Tray detects 2 partitions from the drive, which is correct, but both of these actually open the same partition. In reality, the drive has one msdosfs partition and one NTFS partition.

The system is fully updated PC-BSD 10.0-p5

  1. There are 2 partitions in the menu, where the upper opens the partition correctly. The lower instead, mounts both. Probably related to the number 2.
Last edited 6 months ago by gef_f (previous) (diff)

comment:6 Changed 6 months ago by kenmoore

1) Did you click on the notification "bubble" (but not the little "x" to close the bubble) after the device was attached? That will mount the device for you right then (not an "auto-mount").

2 & 3) I think I found the cause of this. I have a dual-booted system with 2 additional Windows partitions, and it looks like when those partitions are mounted the system device is getting redirected to /dev/fuse instead of the actual device location. Is this what you are seeing?

I am working on a fix for it now.

comment:7 Changed 6 months ago by kenmoore

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:8 Changed 6 months ago by gef_f

I built the mount tray from the updated source and all bugs I mentioned in this ticket look like fixed. The auto-mounting may have happened the way you suspect. I tried it again and I was careful not to click on the popups and indeed, it didn't happen this time.

Note: See TracTickets for help on using tickets.