Opened 9 months ago

Closed 7 months ago

#989 closed System Defect (3rdpartybug)

Keyboard layout switching is broken

Reported by: yurkis Owned by: ken
Priority: major Milestone:
Component: Misc Version: 10.0-RELEASE
Keywords: Cc: trac-bugs@…

Description

I can confirm: Keyboard layout switching is broken (at list in KDE).
I can add keyboard layouts using KDE control center. I even can see keyboard indicator. But I can't switch keyboard layout by previously configured hotkeys or even by mouse!

Change History (8)

comment:1 Changed 9 months ago by kenmoore

There are three utilities vying for keyboard layout control when you are using KDE.
1) Initial system settings as set by PCDM.
2) KDE Keyboard Daemon
3) IBUS
(GNOME/Cinnamon/MATE have a different number 2, and XFCE does not have a number 2 from what I can tell)

For a fresh 10.0 installation, 2 & 3 should be disabled by default (except 3 is auto-started for a short list of particular locales). If you did an upgrade from 9.2, you might need to go into the KDE startup services and disable 2 & 3 manually. I am not sure which of 2 & 3 gets priority, so you might need to manually disable 3 from starting up to ensure that 2 is the controlling service if necessary.

Which locale are you using on your system too? You should be able to check the "LANG" or "LC_ALL" environment variables to get the locale code. That should help narrow down whether the "/usr/local/share/pcbsd/xstartup/enable-ibus.sh" script is detecting one of the special locales for auto-starting IBUS.

comment:2 Changed 9 months ago by yurkis

Hi, Ken

I think that main problem is in KDE Keyboard daemon. That daemon was enabled previously. But now is not. I have uk_UA.UTF-8 locale. Ususally I use english(us), Ukrainian and Russian (Winkeys) keyboard layouts. Alt + Shift I use for layout switching. Also I know people who use another hotkeys and ScrollLock? led as keyboard layout indicator. Currently we have no full featured layout configurator and switcher for whole system. Maybe leaving as is (controlling by each DE) whould be the best solution.

comment:3 Changed 9 months ago by kenmoore

It sounds like you just want to enable IBUS on your system. That is supposed to let you setup quick-switching between different keyboard settings and locale's (and is DE-independent). You can enable it either through your DE's startup services, or by going into the PC-BSD system manager and enabling the "Force IBUS input" option.

Just be warned that you need to setup your IBUS default layout properly, because it will override the system setting that PCDM configures/uses.

comment:4 Changed 9 months ago by joshms

  • Owner set to ken

comment:5 Changed 9 months ago by kenmoore

  • Resolution set to 3rdpartybug
  • Status changed from new to closed

Closing this as a 3rd party bug (KDE Keyboard daemon).
Feel free to re-open it if you have any additional information that we can address.

comment:6 Changed 9 months ago by yurkis

  • Priority changed from critical to major
  • Resolution 3rdpartybug deleted
  • Status changed from closed to reopened

I've just played with IBus. I can't setup layout switching using <Alt>+<Shift> (most popular keystroke for russian/ukrainian spoken people. Seems like keystroke should contain at least one 'not modificator' key. <alt> + space but not just <alt> or <alt>+<shift>. Also I can't find setting to use ScrollLock? as layout indicator (another popular feature).
Anyway I will use KDE keyboard. Looks like really better for me.
Maybe the better solution is to provide setting like this:
(*) Use IBus for all desktop environments
( ) Use desktop environment related keyboard switching
I saw "Force IBus input" setting. Maybe that is it.

comment:7 Changed 8 months ago by kenmoore

yurkis:
Could you check a couple things for me regarding IBUS on your system?
1) Are your packages up-to-date (specifically regarding pcbsd-utils-qt4 for some PCDM fixes)?
2) Set the "Force IBUS Input" option in the system manager and then restart to test:

2-A) Are the QT_IM_MODULE and XMODIFIERS environment variables set in your DE session, and to what?
2-B) Are the GTK_IM_MODULE and GTK_IM_MODULE_FILE environment variables also set?
2-C) Do you see any other IBUS environment variables in your session that PCDM might be able to automatically set on login so that there is a cleaner transition from one to the other?

3) Is the IBUS keyboard shortcut limitations specific to PC-BSD, or is that just the way that IBUS is setup in general?

comment:8 Changed 7 months ago by kenmoore

  • Resolution set to 3rdpartybug
  • Status changed from reopened to closed

In lieu of any new information, I am going to close this as a 3rd party bug again (IBUS configuration/settings).

Feel free to re-open it if you have any additional information regarding an IBUS deficiency specific to PC-BSD.

Note: See TracTickets for help on using tickets.