Changeset c30962e


Ignore:
Timestamp:
05/10/14 06:08:58 (13 months ago)
Author:
Kris Moore <kris@…>
Branches:
master, enter/10, releng/10.0.2, releng/10.0.3, releng/10.1, releng/10.1.1, releng/10.1.2
Children:
1be462f
Parents:
5215583
Message:

When we do a 'pbi migrate' command, make sure packages on system
are updated fully first.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • src-sh/pbi-manager/pbi-manager

    rad35bf5 rc30962e  
    11781178        fi 
    11791179 
     1180        # Duh 
    11801181        require_root 
     1182 
     1183 
     1184        # Before doing any updates, need to make sure packages on system 
     1185        # are up2date 
     1186        pc-updatemanager pkgupdate 
     1187        if [ $? -ne 0 ] ; then 
     1188           exit_err "Packages on system need updating before running 'pbi migrate' again." 
     1189        fi 
    11811190 
    11821191        # Remove user *.desktop files 
Note: See TracChangeset for help on using the changeset viewer.