#1061 closed System Defect (deferred)


Reported by: TGIK Owned by: kris
Priority: major Milestone:
Component: XOrg Configurator Version: 10-STABLE
Keywords: xorg, nvidia, setup wizard Cc: trac-bugs@…


It was requested that I share the difficulty I have had getting PC-BSD to boot into the GUI.

Here are the basic specs of the setup I am using

i5 Intel (internal GPU disable in BIOS)
Z77 Chipset
NVIDIA GTX 660 (primary in PCI:1:0:0
NVIDIA GTX 650 (secondary in PCI:6:0:0)

I will go through the options I choose and what happens when I choose them.

-Regular graphic install

*All goes well until it tries to configure "X' for the install. It creates an endless series of xorg config failures and will not let me break out of it ctrl+alt+f1 f2 etc ---- doesn't work--- all I can do is hit the 'hard reset' button on my PC

-VESA install

*All goes well until it tries to configure "X" for the install. It begins a loop of configuration failures but unlike before this loop of configuration failures eventually ends and gives me a message to manually configure my xorg.conf and use the startx command to enter the installer GUI. This was progress in some ways and being familiar with FreeBSD I felt confident I could edit the config file. I also checked the log file for errors and unsurprisingly found a typical error when using multiple GPU's which is that no screen is found-- in addition the error log said that it could not load the VESA driver for my hardware ---

so I went into the Xorg.conf file and changed the driver from 'Vesa' to 'nvidia' and added the BusID line for my main GPU--
Even without changing monitor settings or anything else after typing startx - I was in the installer GUI at the right resolution.
It was at this point I felt I had worked around the issue--

but I hadn't

The real crux of this problem/bug is during the next boot after installation when it tries to run the display wizard. It again gets caught in an endless loop of configuration fails that does not end. I can break out of 'X' in this situation though --- when looking at my xorg.conf file, it appears on reboot that it is not using the one created for installation but rather defaults back to the generic vesa driver -- this is, I assume, because it 'remembers' that during the initial install I chose 'vesa' and is using that xorg.conf ----as if any changes I make to xorg during install are immediately erased- despite the fact that the NVIDIA drivers were installed and are being loaded in the kernel

so I use the command to stop GDM (which actually doesn't seem to stop the display wizard) and edit the xorg.conf with the nvidia driver----

I save the changes--- sometimes, since the display wizard is still running it seems to see the changes and start to display the GUI but flashes on and off in an endless loop that I cannot break out of.

I am sort of at loss at what to do next --- I have gotten as far as getting it to start to display the GUI on reboot after fiddling with xorg.conf but it just blinks and flashes. But those changes in the xorg.conf file allowed me to enter the install GUI no problem -- I don't understand the relationship between my ability to bring up the GUI installer and my inability to reboot into the GUI.
I also am somewhat handcuffed by the install process of PCBSD since I have not created a root user and thus have no real root authority it seems-- In essence I am lost in the gap between install and system configuration. I know I can generate an xorg.conf that works since I can 'force' my way into the installer -- but I cannot seem to get it past that point -- booting into single use I cannot get the file system to be rw---

The stop GDM, start GDM commands and manual editing of xorg.conf after install is not working --

it seems that neither the open source NV driver nor the vesa driver works with this hardware- only the closed-source nvidia driver.

I have a fully operating FreeBSD 10.0 system with KDE, compiz, etc--
what made that installation easier was that I was in control of starting or not starting 'X' and I had true root authority.

Change History (7)

comment:1 Changed 16 months ago by kenmoore

  • Owner set to kris

If you remove the "/var/.runxsetup" file/flag, it will let you bypass the display wizard and just continue on to the firstboot wizard.

I am going to assign this to kris so that he can take a look a the dual-video card detection issue.

comment:2 Changed 16 months ago by cabpa

On my system, i experienced applications not launching and returning Clutter errors like empathy, totem and cheese because I installed all metapackages including NVIDIA even if I do not have an nvidia card. Then I search in the internet and found solutions from forums to uninstall and reinstall nvidia, xorg and mesa driver. I uninstall nvidia from Package Manager Basic view but still the problem exist. I go to the Advanced view and tried to search with nvidia keyboard, i found that there are still nvidia packages in Advance View. So i uninstall all the remaining nvidia packages in Advance View. Then I restarted and tried launching empathy, totem and and suprisingly they launched successfully. Do the nvidia driver/packages creating a mess on the system in PC-BSD 10?

comment:3 Changed 16 months ago by TGIK

I removed the .runxsetup and then made manual changes to the xorg.conf file --- I was able to boot into the basic X display as root but on reboot the screen would flash on and off, showing the PCBSD logo and the basic "X-display" mouse cursor--

subsequent attempts to boot the basic X desktop as root has resulted in no keyboard or mouse control --

comment:4 Changed 16 months ago by kris

Can you grab the latest 10.0.1 ISO and retest? I've put some fixes into place which improve how it detects video card / BusID's.

comment:5 Changed 15 months ago by TGIK

I did the recent install and it fails with the same error --- what about having the nvidia driver module loaded from the first boot?-- I suggest this because I have found that when installing FreeBSD If I install and load the nvidia module before attempting to configure X -- it works without a hitch. What I used to do was configure X -- have it fail --- install the driver / edit the Xorg file etc.... but if the nvidia module is loaded before I run the initial configuration everything works without manual amendments

comment:6 Changed 13 months ago by kris

Ok, first lets boot to the text menu and confirm that loading NVIDIA fixes the issue. If you drop to emergency shell, run "kldload nvidia" and then "startx" does it work? If not, what error does it fail with?

Also, can you post your pciconf -lv from the system? Since this has an integrated intel which is disabled, I need to see if its still somehow triggering the optimus / hybrid checks we have in place.

comment:7 Changed 11 months ago by joshms

  • Resolution set to deferred
  • Status changed from new to closed

Closed due to inactivity.

Note: See TracTickets for help on using tickets.