#1114 closed System Defect (fixed)

After logout/login systemupdater and life preserver trays are gone

Reported by: q/pa Owned by:
Priority: major Milestone:
Component: System Tool Version: 10.0-RELEASE
Keywords: tray, systemupdater, life preserver Cc: trac-bugs@…

Description

PCBSD 10.0.2 EDGE:

Since today's pkg updates after logging out and logging back in the trays of the system updater and life preserver tools are gone.

Change History (10)

comment:1 Changed 16 months ago by q/pa

Tested this in KDE, LXDE and Fluxbox so far. Always the same, independent from user (with or without admin permissions).

comment:2 Changed 16 months ago by kris

Odd, couple of questions.

Do you have a /home/<username>/.xprofile file, and what is in it?

Also, do you use encryption for your homedir?

comment:3 Changed 16 months ago by q/pa

Thanks for the quick reply!

/home/<username>/.xprofile:

# Setup some extra PATH variables
PATH=/usr/local/share/pcbsd/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:$HOME/bin; export PATH

XDG_DATA_DIRS="/share:/usr/share:/usr/pbi/share:/usr/local/share"
export XDG_DATA_DIRS

XDG_CONFIG_DIRS="/usr/local/etc/xdg:/usr/pbi/etc/xdg"
export XDG_CONFIG_DIRS

# Check for any specific PC-BSD apps we need to start at login
for i in `ls /usr/local/share/pcbsd/xstartup/*`
do
	# Run some task in the background to run in parallel
	if [ $i = "/usr/local/share/pcbsd/xstartup/enable-ibus.sh" ] ; then
		# Cannot work "VARIABLE=value ; export VARIABLE" in the
		# fork(2)ed script.
		if [ -x "${i}" ] ; then . ${i}
		fi
	else
		if [ -x "${i}" ] ; then (. ${i}) & 
		fi
	fi
done

And yes, all user homedirectories are encrypted.

comment:4 Changed 16 months ago by kris

Ok, so the file is correct, probably an issue with the encryption or permissions. Can you run "chmod 755 .xprofile" in your homedir, then reboot and try again?

comment:5 Changed 16 months ago by q/pa

Hm, that did not help. Or do I have to run it as root?

comment:6 Changed 16 months ago by kris

Nope, should be as user..

If you open a shell and run ". ~/.xprofile" when logged in as your user, does it bring up the trays about 30 seconds later?

Also, are you rebooting, or doing a logout / login to test? Try a reboot to be sure. I may have found a bug with PEFS not flushing keys correctly.

comment:7 Changed 16 months ago by q/pa

. ~/.xprofile
/usr/local/bin/.: Permission denied.

I did a reboot before.

comment:8 Changed 16 months ago by kris

Ok, I think I found the bug in PCDM. I'm rebuilding packages for EDGE now and will try to push out the new ones later this night. Once they are available, please try them out and see if the issue is corrected.

comment:9 Changed 16 months ago by q/pa

Problem solved!

And good to see new features like being able to choose what to see in AppCafé?. Be it the installed PBIs or the different kind of packages. I like the new AppCafé? very much - great work, thank you!

comment:10 Changed 16 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

You're welcome, I'll mark this as closed then.

Note: See TracTickets for help on using tickets.